Bug 24120 - REGRESSION (r32862-r32874): www.lostremote.com renders incorrectly
Summary: REGRESSION (r32862-r32874): www.lostremote.com renders incorrectly
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.lostremote.com/
Keywords: HasReduction, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2009-02-24 04:31 PST by David Kilzer (:ddkilzer)
Modified: 2012-10-02 11:57 PDT (History)
4 users (show)

See Also:


Attachments
Original page source + <base> tag (70.61 KB, text/html)
2009-02-25 01:50 PST, David Kilzer (:ddkilzer)
no flags Details
Reduction (480 bytes, text/html)
2009-03-22 15:24 PDT, mitz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2009-02-24 04:31:24 PST
* SUMMARY
The URL <http://www.lostremote.com/> renders incorrectly on the latest WebKit nightly build.  There are supposed to be three columns on the page, but the right two columns are rendered below the column on the left (which is pushed to the right).

* STEPS TO REPRODUCE
1. Launch WebKit nightly build r28007 and WebKit nightly build r41173.
2. Compare page rendering.

* RESULTS
WebKit r28007 renders the page correctly.  WebKit r41173 does not.

* REGRESSION
This is a regression.

* NOTES
I'm running bisect-builds now to narrow down the regression.
Comment 1 David Kilzer (:ddkilzer) 2009-02-24 04:56:41 PST
(In reply to comment #0)
> * NOTES
> I'm running bisect-builds now to narrow down the regression.

Broken revisions skipped: r32877, r32516

Works: r32862  Fails: r32901
Comment 2 David Kilzer (:ddkilzer) 2009-02-24 05:01:13 PST
<rdar://problem/6616563>
Comment 3 David Kilzer (:ddkilzer) 2009-02-24 05:14:21 PST
(In reply to comment #1)
> Works: r32862  Fails: r32901

Internal bisect reports:

Works: r32861  Fails: r32874
Comment 4 David Kilzer (:ddkilzer) 2009-02-24 05:20:30 PST
(In reply to comment #3)
> (In reply to comment #1)
> > Works: r32862  Fails: r32901
> Works: r32861  Fails: r32874

The only layout/rendering-related change in that range is r32872:

http://trac.webkit.org/changeset/32872
Comment 5 David Kilzer (:ddkilzer) 2009-02-24 09:31:07 PST
I suspect the YouTube video on the "Watch as TV Ends" post is causing the misrendering, but I don't have any proof yet.
Comment 6 David Kilzer (:ddkilzer) 2009-02-25 01:50:14 PST
Created attachment 27963 [details]
Original page source + <base> tag
Comment 7 mitz 2009-03-22 15:24:07 PDT
Created attachment 28841 [details]
Reduction

Caused by <http://trac.webkit.org/changeset/32872>. I think the new behavior is correct. Firefox has a tendency to push floats down even if they would fit on the line. See attached reduction.

Hyatt, do you think we can/should "fix" it?
Comment 8 mitz 2009-04-02 14:26:21 PDT
Hyatt and I think that the current layout is correct and this is a bug in the website.
Comment 9 David Kilzer (:ddkilzer) 2009-04-02 14:56:32 PDT
Reopening to give evangelism a chance.
Comment 10 David Kilzer (:ddkilzer) 2009-04-02 15:13:45 PDT
(In reply to comment #9)
> Reopening to give evangelism a chance.

Sent email to tips at lostremote dot com about the issue.
Comment 11 Robert Hogan 2012-10-02 11:57:26 PDT
Looks like this can be closed - though FF14 is still the odd one out on the reduction.