Bug 24118 - RTL: Truncation behaves differently than IE/FF/Opera
Summary: RTL: Truncation behaves differently than IE/FF/Opera
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL: http://dr-george.co.il
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-24 02:13 PST by Jeremy Moskovich
Modified: 2010-10-31 19:38 PDT (History)
7 users (show)

See Also:


Attachments
IE/FF/Opera's behavior - left side is truncated. (85.23 KB, image/png)
2009-02-24 02:23 PST, Jeremy Moskovich
no flags Details
WebKit truncates from the opposite side. (70.67 KB, image/jpeg)
2009-02-24 02:27 PST, Jeremy Moskovich
no flags Details
Testcase (1.83 KB, text/html)
2010-10-27 11:55 PDT, Jeremy Moskovich
no flags Details
Layout test for rtl truncation . (6.15 KB, patch)
2010-10-28 06:55 PDT, Jeremy Moskovich
no flags Details | Formatted Diff | Diff
Patch for landing (74.54 KB, patch)
2010-10-30 22:04 PDT, Jeremy Moskovich
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Moskovich 2009-02-24 02:13:50 PST
Steps to reproduce:
1. Navigate to http://dr-george.co.il
2. Resize the page so the content doesn't fit horizontally and not the direction the content is truncated from.

Expected behavior:
FF/IE/Opera truncate the right side of the page.
WebKit truncates from the left side.

See attached screenshots.
Comment 1 Jeremy Moskovich 2009-02-24 02:17:49 PST
Filed in the Chromium bug db as: http://crbug.com/7764
Comment 2 Jeremy Moskovich 2009-02-24 02:18:22 PST
Sorry, that should be: http://crbug.com/7763
Comment 3 Jeremy Moskovich 2009-02-24 02:23:33 PST
Created attachment 27911 [details]
IE/FF/Opera's behavior - left side is truncated.
Comment 4 Jeremy Moskovich 2009-02-24 02:27:06 PST
Created attachment 27912 [details]
WebKit truncates from the opposite side.
Comment 5 mitz 2009-02-24 12:56:11 PST
Looks related to bug 23556 and bug 3352.
Comment 6 Yair Yogev 2009-05-14 03:59:15 PDT
this is not only a mac issue of course
Comment 7 Xiaomei Ji 2010-10-08 15:53:09 PDT
test URL:
http://www.dentalspace.co.il
Comment 8 Jeremy Moskovich 2010-10-27 11:55:14 PDT
Created attachment 72065 [details]
Testcase

Testcase illustrating the issue.
Comment 9 Jeremy Moskovich 2010-10-27 11:57:03 PDT
Looks like this is now fixed on ToT, leaving open for the sole purpose of creating a layout test if this isn't covered by an existing test.
Comment 10 Jeremy Moskovich 2010-10-28 06:55:38 PDT
Created attachment 72184 [details]
Layout test for rtl truncation .
Comment 11 WebKit Commit Bot 2010-10-28 07:50:22 PDT
Comment on attachment 72184 [details]
Layout test for rtl truncation .

Rejecting patch 72184 from commit-queue.

Failed to run "['./WebKitTools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '--bot-id=abarth-cq-sl', 'apply-attachment', '--force-clean', '--non-interactive', 72184]" exit_code: 2
Last 500 characters of output:
 Git diff contains a binary file without the binary data in line: "Binary files /dev/null and b/LayoutTests/platform/mac/fast/block/basic/truncation-rtl-expected.png differ".  Be sure to use the --binary flag when invoking "git diff" with diffs containing binary files. at /Users/abarth/git/webkit-queue/WebKitTools/Scripts/VCSUtils.pm line 567, <ARGV> line 59.

Failed to run "[u'/Users/abarth/git/webkit-queue/WebKitTools/Scripts/svn-apply', u'--reviewer', u'Ojan Vafai', u'--force']" exit_code: 9

Full output: http://queues.webkit.org/results/4782059
Comment 12 Jeremy Moskovich 2010-10-30 22:04:35 PDT
Created attachment 72450 [details]
Patch for landing
Comment 13 WebKit Commit Bot 2010-10-31 19:37:57 PDT
Comment on attachment 72450 [details]
Patch for landing

Clearing flags on attachment: 72450

Committed r71005: <http://trac.webkit.org/changeset/71005>
Comment 14 WebKit Commit Bot 2010-10-31 19:38:03 PDT
All reviewed patches have been landed.  Closing bug.