Bug 240570 - MediaStreamTrack.applyConstraints with max frameRate throws overconstrained error incorrectly
Summary: MediaStreamTrack.applyConstraints with max frameRate throws overconstrained e...
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: WebKit Nightly Build
Hardware: Mac (Intel) macOS 12
: P2 Major
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2022-05-18 04:01 PDT by Arjun Vade
Modified: 2022-06-23 02:23 PDT (History)
4 users (show)

See Also:


Attachments
reproducible test case (1.27 KB, text/html)
2022-05-18 04:01 PDT, Arjun Vade
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arjun Vade 2022-05-18 04:01:04 PDT
Created attachment 459534 [details]
reproducible test case

Steps to reproduce:
1. run the html file attached in safari browser
2. click the button
3. notice that second video element is not showing anything. Open the dev tools console and notice the overconstrained error

There should not be overconstrained error because same applyConstraints with simple `{ frameRate: 8 }` works fine.
Comment 1 Radar WebKit Bug Importer 2022-05-18 09:54:50 PDT
<rdar://problem/93509993>
Comment 2 youenn fablet 2022-06-23 02:23:49 PDT
This works fine in STP 147, closing bug.
Please reopen if you are still able to reproduce.