Bug 240544 - [ iOS ] editing/selection/ios/show-callout-bar-after-selecting-word.html is a flaky timeout
Summary: [ iOS ] editing/selection/ios/show-callout-bar-after-selecting-word.html is a...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Wenson Hsieh
URL:
Keywords: InRadar
: 241761 (view as bug list)
Depends on:
Blocks: 241837
  Show dependency treegraph
 
Reported: 2022-05-17 15:33 PDT by Matteo Flores
Modified: 2022-06-22 09:08 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matteo Flores 2022-05-17 15:33:02 PDT
editing/selection/ios/show-callout-bar-after-selecting-word.html
is a flaky timeout on iOS queues

HISTORY:
https://results.webkit.org/?suite=layout-tests&test=editing%2Fselection%2Fios%2Fshow-callout-bar-after-selecting-word.html

DIFF:
--- /Volumes/Data/worker/Apple-iOS-15-Simulator-Release-WK2-Tests/build/layout-test-results/editing/selection/ios/show-callout-bar-after-selecting-word-expected.txt
+++ /Volumes/Data/worker/Apple-iOS-15-Simulator-Release-WK2-Tests/build/layout-test-results/editing/selection/ios/show-callout-bar-after-selecting-word-actual.txt
@@ -1,11 +1,9 @@
+FAIL: Timed out waiting for notifyDone to be called
+
+WebKit
 This test verifies that the callout bar is shown after selecting a word in an editable element using the callout bar. To test manually, focus the editable area and tap 'Select' in the callout bar; the callout bar should appear again, with an option to 'Copy'.
 
 On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
 
 PASS Showed menu by tapping
-PASS Selected word using menu action
-PASS Callout bar contains 'Copy' action
-PASS successfullyParsed is true
 
-TEST COMPLETE
-

DIFF-URL:
https://build.webkit.org/results/Apple-iOS-15-Simulator-Release-WK2-Tests/250643@main%20(2626)/editing/selection/ios/show-callout-bar-after-selecting-word-diff.txt
Comment 1 Matteo Flores 2022-05-17 15:47:01 PDT
I was unable to recreate with run-webkit-tests at TOT, even using multiple iterations. 

First timeout appears to have been around r291181
Comment 2 Radar WebKit Bug Importer 2022-05-17 15:47:10 PDT
<rdar://problem/93458507>
Comment 3 Wenson Hsieh 2022-06-19 16:45:40 PDT
*** Bug 241761 has been marked as a duplicate of this bug. ***
Comment 4 Wenson Hsieh 2022-06-19 16:46:35 PDT
I'll use this bug to track the fact that this test is flaky on iOS 15, and always times out on iOS 16.
Comment 5 Wenson Hsieh 2022-06-19 16:48:39 PDT
Pull request: https://github.com/WebKit/WebKit/pull/1626
Comment 6 EWS 2022-06-22 09:08:22 PDT
Committed r295732 (251737@main): <https://commits.webkit.org/251737@main>

Reviewed commits have been landed. Closing PR #1626 and removing active labels.