Bug 240467 - jsc's settimeout should h properly handle a delay
Summary: jsc's settimeout should h properly handle a delay
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Keith Miller
URL:
Keywords: InRadar
: 240465 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-05-16 10:52 PDT by Keith Miller
Modified: 2022-06-09 12:06 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Miller 2022-05-16 10:52:16 PDT
Right now the second parameter of settimeout in the shell is ignored we should treat is  as a delay like on the web.
Comment 1 Keith Miller 2022-05-16 10:55:44 PDT
Pull request: https://github.com/WebKit/WebKit/pull/641
Comment 2 Alexey Proskuryakov 2022-05-16 17:13:01 PDT
*** Bug 240465 has been marked as a duplicate of this bug. ***
Comment 3 Radar WebKit Bug Importer 2022-05-23 10:53:14 PDT
<rdar://problem/93771307>
Comment 4 EWS 2022-06-09 12:06:04 PDT
Committed r295428 (251434@main): <https://commits.webkit.org/251434@main>

Reviewed commits have been landed. Closing PR #641 and removing active labels.