Bug 240401 - [Repaint] Border ignores currentColor change when hovering
Summary: [Repaint] Border ignores currentColor change when hovering
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: zalan
URL:
Keywords: InRadar
: 223654 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-05-13 15:27 PDT by zalan
Modified: 2022-05-14 22:40 PDT (History)
22 users (show)

See Also:


Attachments
Patch (17.97 KB, patch)
2022-05-13 16:35 PDT, zalan
no flags Details | Formatted Diff | Diff
Patch (15.18 KB, patch)
2022-05-13 18:40 PDT, zalan
no flags Details | Formatted Diff | Diff
Patch (19.54 KB, patch)
2022-05-14 06:53 PDT, zalan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description zalan 2022-05-13 15:27:52 PDT
ssia
Comment 1 zalan 2022-05-13 16:35:57 PDT
Created attachment 459328 [details]
Patch
Comment 2 zalan 2022-05-13 18:40:41 PDT
Created attachment 459337 [details]
Patch
Comment 3 Tim Nguyen (:ntim) 2022-05-14 00:04:01 PDT
Is bug 223654 a duplicate?
Comment 4 Tim Nguyen (:ntim) 2022-05-14 00:05:18 PDT
Comment on attachment 459337 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=459337&action=review

> LayoutTests/ChangeLog:12
> +        * fast/repaint/repaint-current-color-border-on-hover-expected.txt: Added.
> +        * fast/repaint/repaint-current-color-border-on-hover.html: Added.
> +        * fast/repaint/repaint-pseudo-border-on-hover-expected.txt: Added.
> +        * fast/repaint/repaint-pseudo-border-on-hover.html: Added.
> +

These files are not in the patch
Comment 5 zalan 2022-05-14 05:34:04 PDT
(In reply to Tim Nguyen (:ntim) from comment #4)
> Comment on attachment 459337 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=459337&action=review
> 
> > LayoutTests/ChangeLog:12
> > +        * fast/repaint/repaint-current-color-border-on-hover-expected.txt: Added.
> > +        * fast/repaint/repaint-current-color-border-on-hover.html: Added.
> > +        * fast/repaint/repaint-pseudo-border-on-hover-expected.txt: Added.
> > +        * fast/repaint/repaint-pseudo-border-on-hover.html: Added.
> > +
> 
> These files are not in the patch
oops
Comment 6 Antti Koivisto 2022-05-14 05:39:53 PDT
Comment on attachment 459337 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=459337&action=review

> Source/WebCore/rendering/style/BorderData.h:114
> +        return !currentColorDiffers || (m_top.color().isValid() && m_right.color().isValid() && m_bottom.color().isValid() && m_left.color().isValid());

Might be more stylish to use RenderStyle::isCurrentColor(m_top.color()) etc.
Comment 7 zalan 2022-05-14 06:53:00 PDT
Created attachment 459355 [details]
Patch
Comment 8 zalan 2022-05-14 06:58:35 PDT
(In reply to zalan from comment #5)
> (In reply to Tim Nguyen (:ntim) from comment #4)
> > Comment on attachment 459337 [details]
> > Patch
> > 
> > View in context:
> > https://bugs.webkit.org/attachment.cgi?id=459337&action=review
> > 
> > > LayoutTests/ChangeLog:12
> > > +        * fast/repaint/repaint-current-color-border-on-hover-expected.txt: Added.
> > > +        * fast/repaint/repaint-current-color-border-on-hover.html: Added.
> > > +        * fast/repaint/repaint-pseudo-border-on-hover-expected.txt: Added.
> > > +        * fast/repaint/repaint-pseudo-border-on-hover.html: Added.
> > > +
> > 
> > These files are not in the patch
> oops
webkit-patch land is messing with my local state.
Comment 9 EWS 2022-05-14 08:25:41 PDT
Committed r294195 (250561@main): <https://commits.webkit.org/250561@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 459355 [details].
Comment 10 Radar WebKit Bug Importer 2022-05-14 08:26:14 PDT
<rdar://problem/93291192>
Comment 11 Tim Nguyen (:ntim) 2022-05-14 22:40:46 PDT
*** Bug 223654 has been marked as a duplicate of this bug. ***