Bug 239967 - [CSS Cascade Layers] Endless recursion with revert-layer in other tree context
Summary: [CSS Cascade Layers] Endless recursion with revert-layer in other tree context
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antti Koivisto
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2022-05-02 08:51 PDT by Brandon
Modified: 2022-05-03 08:46 PDT (History)
4 users (show)

See Also:


Attachments
Patch (9.45 KB, patch)
2022-05-03 06:43 PDT, Antti Koivisto
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brandon 2022-05-02 08:51:19 PDT
<rdar://92449950>
Comment 1 Brandon 2022-05-02 08:51:42 PDT
Test Case:

<style>
  ::-webkit-input-placeholder {
    display: revert-layer;
  }
</style>
<input placeholder="a">
Comment 2 Brandon 2022-05-02 12:22:22 PDT
The issue is occurring here due to constant back and forth between applyProperty and applyRollbackCascadeProperty. This accumulates into an endless recursion that eventually crashes.

We need a way to add an exit condition here.
Comment 3 Antti Koivisto 2022-05-03 06:43:36 PDT
Created attachment 458737 [details]
Patch
Comment 4 Antti Koivisto 2022-05-03 06:47:31 PDT
Also https://github.com/web-platform-tests/wpt/pull/33907
Comment 5 EWS 2022-05-03 08:46:36 PDT
Committed r293725 (250213@main): <https://commits.webkit.org/250213@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 458737 [details].