Bug 23982 - REGRESSION: Search field loses keyboard focus once a match is found
Summary: REGRESSION: Search field loses keyboard focus once a match is found
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Timothy Hatcher
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2009-02-16 16:12 PST by Geoffrey Garen
Modified: 2009-04-03 17:42 PDT (History)
3 users (show)

See Also:


Attachments
Proposed Patch (2.09 KB, patch)
2009-04-03 17:18 PDT, Timothy Hatcher
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey Garen 2009-02-16 16:12:33 PST
The Web Inspector's search field loses focus once a match is found. This makes it impossible to keep typing, so you often end up with something not very helpful selected.

TO REPRODUCE:
1. Navigate to google.com
2. Start debugging.
3. In the Scripts pane's search field, type "ret"
--> Notice that the search field loses focus, and "ret" in "return" is selected in the google.com source.
Comment 1 Geoffrey Garen 2009-02-16 16:13:48 PST
<rdar://problem/6592367>
Comment 2 Patrick Mueller 2009-03-20 07:48:17 PDT
Unable to reproduce in r41844 on Mac.  Has this been fixed already?
Comment 3 Timothy Hatcher 2009-03-20 09:19:04 PDT
I can't reproduce either. Sounds like it might have been a temporary regression.
Comment 4 Timothy Hatcher 2009-03-20 09:21:13 PDT
Actually it still reproduces in the Scripts panel, and seems to only be a problem in that panel and Resources.
Comment 5 Timothy Hatcher 2009-03-20 09:22:14 PDT
Oddly focus looks like it is in the search field (there is still a focus ring) but there is no blinking insertion caret and no keyboard events reach the search field.
Comment 6 Timothy Hatcher 2009-04-03 17:18:08 PDT
Created attachment 29247 [details]
Proposed Patch
Comment 7 Darin Adler 2009-04-03 17:26:09 PDT
Comment on attachment 29247 [details]
Proposed Patch

r=me
Comment 8 Timothy Hatcher 2009-04-03 17:42:01 PDT
Landed in r42221.