Bug 239361 - Use WebCoreBuiltinNames when possible
Summary: Use WebCoreBuiltinNames when possible
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Bindings (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2022-04-14 17:09 PDT by Chris Dumez
Modified: 2022-04-15 16:24 PDT (History)
18 users (show)

See Also:


Attachments
Patch (66.26 KB, patch)
2022-04-14 17:10 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (66.53 KB, patch)
2022-04-14 17:57 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2022-04-14 17:09:08 PDT
Use WebCoreBuiltinNames when possible to avoid unnecessary calls to Identifier::fromString(). This is more efficient.
Comment 1 Chris Dumez 2022-04-14 17:10:24 PDT
Created attachment 457657 [details]
Patch
Comment 2 Yusuke Suzuki 2022-04-14 17:20:16 PDT
Comment on attachment 457657 [details]
Patch

r=me
Comment 3 Chris Dumez 2022-04-14 17:57:45 PDT
Created attachment 457658 [details]
Patch
Comment 4 EWS 2022-04-14 22:45:37 PDT
Committed r292899 (249669@main): <https://commits.webkit.org/249669@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 457658 [details].
Comment 5 Radar WebKit Bug Importer 2022-04-14 22:46:14 PDT
<rdar://problem/91796246>
Comment 6 Darin Adler 2022-04-15 14:08:31 PDT
Comment on attachment 457658 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=457658&action=review

> Source/WebCore/bindings/js/WebCoreJSClientData.h:211
> +ALWAYS_INLINE WebCoreBuiltinNames& webCoreBuiltinNames(JSC::VM& vm)

Why not call this WebCore::builtInNames instead of WebCore::webCoreBuiltinNames?