Bug 239315 - [ iOS ] TestWebKitAPI.WebKit2.CrashGPUProcessWhileCapturing is a flaky timeout
Summary: [ iOS ] TestWebKitAPI.WebKit2.CrashGPUProcessWhileCapturing is a flaky timeout
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2022-04-13 17:07 PDT by Matteo Flores
Modified: 2022-06-20 06:05 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matteo Flores 2022-04-13 17:07:43 PDT
TestWebKitAPI.WebKit2.CrashGPUProcessWhileCapturing
is a flaky timeout on iOS queues

HISTORY:
https://results.webkit.org/?suite=api-tests&test=TestWebKitAPI.WebKit2.CrashGPUProcessWhileCapturing

TIMEOUT:
 TestWebKitAPI.WebKit2.CrashGPUProcessWhileCapturing
        2022-04-13 12:57:08.100 TestWebKitAPI[1061:760541] Writing analzed variants.
        MessageReceiveQueueMap::addImpl - adding duplicate any id receiver 35
        2022-04-13 12:57:10.206 TestWebKitAPI[1061:760541] Encountered error: Error Domain=WKErrorDomain Code=4 "A JavaScript exception occurred" UserInfo={WKJavaScriptExceptionLineNumber=1, WKJavaScriptExceptionMessage=ReferenceError: Can't find variable: createConnection, WKJavaScriptExceptionColumnNumber=17, WKJavaScriptExceptionSourceURL=undefined, NSLocalizedDescription=A JavaScript exception occurred} while evaluating script: createConnection()

STDIO-URL:
https://results.webkit.org/?suite=api-tests&test=TestWebKitAPI.WebKit2.CrashGPUProcessWhileCapturing
Comment 1 Radar WebKit Bug Importer 2022-04-13 17:08:06 PDT
<rdar://problem/91724349>
Comment 2 Matteo Flores 2022-04-13 19:35:14 PDT
Disabled test to help EWS
Comment 3 Matteo Flores 2022-04-13 19:35:50 PDT
(In reply to Matteo Flores from comment #2)
> Disabled test to help EWS

r292853 **
Comment 4 Matteo Flores 2022-04-20 18:36:26 PDT
Failed to reproduce on iOS TOT using run-api-tests

Interestingly there is a pop-up that may need to be accepted to resolve timeout.
Comment 5 youenn fablet 2022-06-19 23:55:04 PDT
We should probably not disable the tests in macOS since they are running fine there.
Comment 6 youenn fablet 2022-06-19 23:59:42 PDT
Pull request: https://github.com/WebKit/WebKit/pull/1635
Comment 7 youenn fablet 2022-06-20 04:46:11 PDT
Tests seem to pass on EWS, let's try to reland them and monitor the potential fallouts.
Comment 8 EWS 2022-06-20 06:05:42 PDT
Committed r295674 (251679@main): <https://commits.webkit.org/251679@main>

Reviewed commits have been landed. Closing PR #1635 and removing active labels.