Bug 238955 - Broaden TypedArray API fix to all apps not just Bleacher Report
Summary: Broaden TypedArray API fix to all apps not just Bleacher Report
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Keith Miller
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2022-04-07 13:12 PDT by Keith Miller
Modified: 2022-04-08 16:06 PDT (History)
10 users (show)

See Also:


Attachments
Patch (3.79 KB, patch)
2022-04-07 13:14 PDT, Keith Miller
saam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Miller 2022-04-07 13:12:03 PDT
Broaden TypedArray API fix to all apps not just Bleacher Report
Comment 1 Keith Miller 2022-04-07 13:14:02 PDT
Created attachment 456960 [details]
Patch
Comment 2 Saam Barati 2022-04-07 13:17:59 PDT
Comment on attachment 456960 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=456960&action=review

r=me

> Source/JavaScriptCore/API/JSTypedArray.cpp:369
> +inline static bool isLinkedBeforeQuirk()

let's call this "isLinkedBeforeTypedArrayLengthQuirk"?
Comment 3 Keith Miller 2022-04-08 09:41:16 PDT
Committed r292609 (?): <https://commits.webkit.org/r292609>
Comment 4 Radar WebKit Bug Importer 2022-04-08 09:42:17 PDT
<rdar://problem/91487064>
Comment 5 Darin Adler 2022-04-08 10:07:14 PDT
Comment on attachment 456960 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=456960&action=review

>> Source/JavaScriptCore/API/JSTypedArray.cpp:369
>> +inline static bool isLinkedBeforeQuirk()
> 
> let's call this "isLinkedBeforeTypedArrayLengthQuirk"?

Typically in the past I have named such functions needsTypedArrayAPIQuirk() rather than specifying how the functions do their jobs. I think it’s easier to read at the call site.
Comment 6 Saam Barati 2022-04-08 16:06:54 PDT
(In reply to Darin Adler from comment #5)
> Comment on attachment 456960 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=456960&action=review
> 
> >> Source/JavaScriptCore/API/JSTypedArray.cpp:369
> >> +inline static bool isLinkedBeforeQuirk()
> > 
> > let's call this "isLinkedBeforeTypedArrayLengthQuirk"?
> 
> Typically in the past I have named such functions needsTypedArrayAPIQuirk()
> rather than specifying how the functions do their jobs. I think it’s easier
> to read at the call site.

I agree this is a better name and aids readability.