Bug 237950 - [Model] A long press on a <model> infinitely corrupts the touch events send to its WKModelView
Summary: [Model] A long press on a <model> infinitely corrupts the touch events send t...
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: UI Events (show other bugs)
Version: Safari Technology Preview
Hardware: iPhone / iPad iOS 15
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2022-03-16 02:41 PDT by Thomas Kumlehn
Modified: 2022-08-17 10:57 PDT (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Kumlehn 2022-03-16 02:41:34 PDT
After a first long tap/press on a <model> any future single finger drag is interpreted as a two finger event.
So a simple rotate gesture becomes a zoom/dolly.
The next long press totally halts interactions with the modelElement, probably because it's interpreted as a 3-finger gesture.
Comment 1 Thomas Kumlehn 2022-03-16 03:01:31 PDT
The first long tap selected the word preceding the model tag.
Comment 2 Radar WebKit Bug Importer 2022-03-16 05:42:03 PDT
<rdar://problem/90364936>
Comment 3 Antoine Quint 2022-03-16 10:12:07 PDT
Thanks for filing this Thomas. Which iOS version is that?
Comment 4 Thomas Kumlehn 2022-03-17 05:03:25 PDT
iPadOS 15.4
Comment 5 Thomas Kumlehn 2022-03-17 05:06:16 PDT
but it happened before and was reported in Feedback.app as part of other <model> related problems for iOS15.3
Comment 6 Antoine Quint 2022-03-17 07:44:06 PDT
Would you have the id for the issue as reported through the Feedback app?
Comment 7 Thomas Kumlehn 2022-03-21 01:49:21 PDT
It was mixed in with a macOS related bug reported as FB9822366, that was already fixed.
I should have investigated further and should have reported those separately.
Comment 8 Thomas Kumlehn 2022-03-22 07:21:18 PDT
Someone did a really bad job in following the steps that cause the problem, I also reported specifically for iPadOS as FB9951062, so I made a screen recording showing the problem.

The newly attached screen recording shows how I use two fingers to dolly close to the asset, then do a single finger long press. All following interactions are single touch only, but behave unexpected and totally different to a similar session without long press.

I very much hope <model> can be introduced this year, so please let more qualified/motivated developers work on the fixes. Would be very embarrassing otherwise if this (IMHO) blocking bug stays.
Comment 9 Thomas Kumlehn 2022-04-21 01:46:30 PDT
I updated to iPadOS 15.5 public beta 2 and now the same problem occurs when opening the USDZ as a stand alone model document.
The long press shows a kind of capsule shaped loop instead of selecting nearby text, but it also jeopardises the touch events the same way.
A single touch event is interpreted as a multi touch.
Every long press adds another finger not being lifted.
Comment 10 Antoine Quint 2022-04-22 02:56:54 PDT
That behavior is consistent since loading the USDZ file as a standalone document yields a <model> element.
Comment 11 Thomas Kumlehn 2022-05-12 14:32:56 PDT
Problem persists with iPadOS 15.5 RC
Comment 12 Thomas Kumlehn 2022-05-19 13:41:42 PDT
Bug persists in iPadOS 15.6 (19G5027e)
Comment 13 Thomas Kumlehn 2022-06-07 00:37:38 PDT
persists in iPadOS16beta
Comment 14 Thomas Kumlehn 2022-06-07 01:07:35 PDT
Besides of a long press, also one of more other events seem to bring the tap events out of synch. I tested avoiding a long press and it still happened - don't know what kind of finger event it was.
Comment 15 Thomas Kumlehn 2022-06-23 02:11:31 PDT
Problem not solved with iPadOS 16.0 beta2 (20A5303i)
Comment 16 Thomas Kumlehn 2022-07-07 13:30:52 PDT
Same problem on iPadOS 16 beta 3 (20A5312g)
Comment 17 Thomas Kumlehn 2022-07-18 08:07:33 PDT
Bug still not fixed in iPadOS 16 beta (20A5312j)
Comment 18 Thomas Kumlehn 2022-07-28 02:53:57 PDT
bug persists on iPadOS16 (20A5328h)
Comment 19 Thomas Kumlehn 2022-08-09 10:46:27 PDT
bug persists on iPadOS16 (20A5339d)
Comment 20 Thomas Kumlehn 2022-08-17 03:59:16 PDT
Not fixed in iPadOS 16.0 (20A5349b)
Comment 21 Dean Jackson 2022-08-17 10:57:51 PDT
You'll see here when it is fixed :)