Bug 237093 - REGRESSION(r289683): [GTK][WPE] Scrolling with the mouse wheel doesn't work in twitter after r289683
Summary: REGRESSION(r289683): [GTK][WPE] Scrolling with the mouse wheel doesn't work i...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nikos Mouchtaris
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2022-02-23 09:55 PST by Carlos Garcia Campos
Modified: 2022-03-01 03:02 PST (History)
6 users (show)

See Also:


Attachments
test case (root element with overscroll-behavior-y:none) (143 bytes, text/html)
2022-02-23 13:18 PST, Fujii Hironori
no flags Details
Patch (1.44 KB, patch)
2022-02-23 15:49 PST, Nikos Mouchtaris
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2022-02-23 09:55:21 PST
I guess overscroll-behavior is not supported or broken for GTK/WPE, so we should enable it by default only for other ports at least for now.
Comment 1 Fujii Hironori 2022-02-23 12:20:59 PST
Good catch. for WinCairo WK2, too.
Comment 2 Fujii Hironori 2022-02-23 12:44:55 PST
The root html element's style attribute has "overscroll-behavior-y: none;".
If I disable this property with Web Inspector, WinCairo can scroll with the mouse wheel.

However, in Mac MiniBrowser, the root html element's style attribute doesn't have "overscroll-behavior-y: none;".
Is this a GTK/WPE/WinCairo bug?
Comment 3 Fujii Hironori 2022-02-23 13:13:21 PST
(In reply to Fujii Hironori from comment #2)
> However, in Mac MiniBrowser, the root html element's style attribute doesn't
> have "overscroll-behavior-y: none;".
> Is this a GTK/WPE/WinCairo bug?

This is my mistake. Because it's still a experimental feature, I need to enable it.
After enabling it, the root html element's style attribute has "overscroll-behavior-y: none;", and Mac MiniBrowser can scrool the page with mouse wheel.
Comment 4 Fujii Hironori 2022-02-23 13:18:20 PST
Created attachment 453020 [details]
test case (root element with overscroll-behavior-y:none)
Comment 5 Nikos Mouchtaris 2022-02-23 15:49:59 PST
Created attachment 453037 [details]
Patch
Comment 6 EWS 2022-02-24 00:58:39 PST
Committed r290417 (247725@main): <https://commits.webkit.org/247725@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 453037 [details].