Bug 236935 - [WebGPU] Use block-based callbacks instead of C function pointer callbacks
Summary: [WebGPU] Use block-based callbacks instead of C function pointer callbacks
Status: RESOLVED DUPLICATE of bug 237932
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGPU (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Myles C. Maxfield
URL:
Keywords: InRadar
Depends on: 236934
Blocks:
  Show dependency treegraph
 
Reported: 2022-02-20 01:03 PST by Myles C. Maxfield
Modified: 2022-03-15 16:50 PDT (History)
3 users (show)

See Also:


Attachments
WIP - Not for review (69.41 KB, patch)
2022-02-20 01:05 PST, Myles C. Maxfield
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Myles C. Maxfield 2022-02-20 01:03:01 PST
.
Comment 1 Myles C. Maxfield 2022-02-20 01:03:13 PST
It turns out we can't actually use this just yet because blocks have to be copyable, which means any lambdas we convert to blocks have to be copyable, but in the GPU Process we receive a CompletionHandler to call back with a reply, but CompletionHandlers are not copyable, so we can't construct the block to pass in to WebGPU.framework.
Comment 2 Myles C. Maxfield 2022-02-20 01:05:07 PST
Created attachment 452686 [details]
WIP - Not for review
Comment 3 Radar WebKit Bug Importer 2022-02-27 01:03:18 PST
<rdar://problem/89523528>
Comment 4 Myles C. Maxfield 2022-03-15 16:50:14 PDT

*** This bug has been marked as a duplicate of bug 237932 ***