Bug 236723 - Bindings generator can't handle (Foo or undefined)
Summary: Bindings generator can't handle (Foo or undefined)
Status: RESOLVED DUPLICATE of bug 232734
Alias: None
Product: WebKit
Classification: Unclassified
Component: Bindings (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks: 232558
  Show dependency treegraph
 
Reported: 2022-02-16 11:42 PST by Myles C. Maxfield
Modified: 2022-03-02 16:03 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Myles C. Maxfield 2022-02-16 11:42:45 PST
https://gpuweb.github.io/gpuweb/#gpuobjectbase

interface mixin GPUObjectBase {
    attribute (USVString or undefined) label;
};

Our bindings generator is turning that into std::variant<WTF::String, void>
Comment 1 Radar WebKit Bug Importer 2022-02-23 11:43:17 PST
<rdar://problem/89368887>
Comment 2 Myles C. Maxfield 2022-03-02 16:03:08 PST
This is probably a dup of https://bugs.webkit.org/show_bug.cgi?id=232734

*** This bug has been marked as a duplicate of bug 232734 ***