Bug 236465 - Web Inspector: click to re-enable breakpoint clears automatic continue
Summary: Web Inspector: click to re-enable breakpoint clears automatic continue
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: Safari 15
Hardware: All macOS 12
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2022-02-10 15:20 PST by Jeff Johnson
Modified: 2022-02-11 15:22 PST (History)
4 users (show)

See Also:


Attachments
[fast-cq] Patch (4.59 KB, patch)
2022-02-11 13:04 PST, Devin Rousso
ews-feeder: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Johnson 2022-02-10 15:20:18 PST
Steps to reproduce:
1. Create new breakpoint
2. Add Action
3. Enter some JavaScript to evaluate
3. Select "Automatically continue after evaluating"
4. Close popup
5. Click the new breakpoint to disable
6. Click the new breakpoint again to enable

Expected results:
Automatically continue after evaluating is enabled.

Actual results:
Automatically continue after evaluating is disabled.

This behavior is very problematic when I need to repeatedly disable and re-enable a breakpoint.
Comment 1 Patrick Angle 2022-02-10 18:26:18 PST
Currently clicking on a breakpoint with actions will cycle through `Enabled without continue` -> `Enabled /w continue` -> `Disabled` in an effort to make it easier to switch between the first two states in cases where you may only want to pause sometimes, but always want the actions to be run. This was implemented in r161687.
Comment 2 Jeff Johnson 2022-02-10 18:42:12 PST
(In reply to Patrick Angle from comment #1)
> Currently clicking on a breakpoint with actions will cycle through `Enabled
> without continue` -> `Enabled /w continue` -> `Disabled` in an effort to
> make it easier to switch between the first two states in cases where you may
> only want to pause sometimes, but always want the actions to be run. This
> was implemented in r161687.

This 3-way toggle doesn't seem very discoverable, especially since all other breakpoints are click on, click off.

Might I suggest a little separate widget to the left of breakpoints that have an action, and thus have the Automatically continue option? Then the breakpoint and Automatically continue can be separately toggled easily.
Comment 3 Jeff Johnson 2022-02-10 19:16:29 PST
Just looking at Xcode for comparison. Xcode does not have a 3-way toggle. However, Xcode does open the breakpoint popup for editing on double-click, whereas the web inspector does not. Thus, it may be a good alternative for the web inspector to edit the breakpoint on double-click.
Comment 4 Devin Rousso 2022-02-11 13:04:40 PST
Created attachment 451736 [details]
[fast-cq] Patch
Comment 5 Patrick Angle 2022-02-11 13:40:31 PST
Comment on attachment 451736 [details]
[fast-cq] Patch

r=me
Comment 6 EWS 2022-02-11 13:47:59 PST
Committed r289669 (247157@main): <https://commits.webkit.org/247157@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 451736 [details].
Comment 7 Radar WebKit Bug Importer 2022-02-11 13:49:14 PST
<rdar://problem/88833824>