Bug 236325 - REGRESSION (r288804): fast/forms/visual-hebrew-text-field.html is failing
Summary: REGRESSION (r288804): fast/forms/visual-hebrew-text-field.html is failing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ryosuke Niwa
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2022-02-08 13:25 PST by Truitt Savell
Modified: 2022-02-14 18:17 PST (History)
9 users (show)

See Also:


Attachments
Patch (1.46 KB, patch)
2022-02-14 15:28 PST, Ryosuke Niwa
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Truitt Savell 2022-02-08 13:25:55 PST
fast/forms/visual-hebrew-text-field.html

this test is failing constantly after the changes in https://trac.webkit.org/changeset/288804/webkit

History:
https://results.webkit.org/?suite=layout-tests&test=fast%2Fforms%2Fvisual-hebrew-text-field.html

Diff:
--- /Volumes/Data/worker/monterey-release-applesilicon-tests-wk2/build/layout-test-results/fast/forms/visual-hebrew-text-field-expected.txt
+++ /Volumes/Data/worker/monterey-release-applesilicon-tests-wk2/build/layout-test-results/fast/forms/visual-hebrew-text-field-actual.txt
@@ -3,26 +3,27 @@
 layer at (0,0) size 800x600
   RenderBlock {HTML} at (0,0) size 800x600
     RenderBody {BODY} at (8,8) size 784x584
-      RenderBlock {P} at (0,0) size 784x36
-        RenderText {#text} at (0,0) size 218x18
-          text run at (0,0) width 218: "This tests for a regression against "
-        RenderInline {I} at (0,0) size 783x36
-          RenderInline {A} at (0,0) size 354x18 [color=#0000EE]
-            RenderText {#text} at (217,0) size 354x18
-              text run at (217,0) width 354: "http://bugzilla.opendarwin.org/show_bug.cgi?id=8076"
-          RenderText {#text} at (570,0) size 783x36
-            text run at (570,0) width 213: " REGRESSION: native text fields"
-            text run at (0,18) width 251: "are reversed on \"visual Hebrew\" pages"
-        RenderText {#text} at (250,18) size 5x18
-          text run at (250,18) width 5: "."
-      RenderBlock {HR} at (0,52) size 784x2 [border: (1px inset #000000)]
-      RenderBlock {P} at (0,70) size 784x19
-        RenderText {#text} at (0,1) size 286x18
-          text run at (0,1) width 286: "Text in the field should look like this: \x{5E8}\x{5D5}\x{5EA}\x{5E4}\x{5DB}"
-      RenderBlock (anonymous) at (0,105) size 784x23
-        RenderTextControl {INPUT} at (2,2) size 147x19 [bgcolor=#FFFFFF] [border: (2px inset #000000)]
+      RenderBlock {P} at (0,0) size 784x84
+        RenderText {#text} at (0,0) size 327x28
+          text run at (0,0) width 327: "This tests for a regression against "
+        RenderInline {I} at (0,0) size 774x84
+          RenderInline {A} at (0,0) size 774x56 [color=#0000EE]
+            RenderText {#text} at (326,0) size 774x56
+              text run at (326,0) width 448: "http://bugzilla.opendarwin.org/show_bug.cgi?"
+              text run at (0,28) width 83: "id=8076"
+          RenderText {#text} at (82,28) size 720x56
+            text run at (82,28) width 638: " REGRESSION: native text fields are reversed on \"visual Hebrew\""
+            text run at (0,56) width 56: "pages"
+        RenderText {#text} at (55,56) size 7x28
+          text run at (55,56) width 7: "."
+      RenderBlock {HR} at (0,108) size 784x2 [border: (1px inset #000000)]
+      RenderBlock {P} at (0,134) size 784x29
+        RenderText {#text} at (0,1) size 429x28
+          text run at (0,1) width 429: "Text in the field should look like this: \x{5E8}\x{5D5}\x{5EA}\x{5E4}\x{5DB}"
+      RenderBlock (anonymous) at (0,187) size 784x38
+        RenderTextControl {INPUT} at (2,2) size 302x34 [bgcolor=#FFFFFF] [border: (2px inset #000000)]
         RenderText {#text} at (0,0) size 0x0
-layer at (13,118) size 141x13
-  RenderBlock {DIV} at (3,3) size 141x13
-    RenderText {#text} at (0,0) size 31x13
-      text run at (0,0) width 31 RTL: "\x{5DB}\x{5E4}\x{5EA}\x{5D5}\x{5E8}"
+layer at (13,200) size 296x28
+  RenderBlock {DIV} at (3,3) size 296x28
+    RenderText {#text} at (0,0) size 66x28
+      text run at (0,0) width 66 RTL: "\x{5DB}\x{5E4}\x{5EA}\x{5D5}\x{5E8}"
Comment 1 Radar WebKit Bug Importer 2022-02-08 13:27:09 PST
<rdar://problem/88648904>
Comment 2 Ryosuke Niwa 2022-02-09 11:33:28 PST
Huh, very strange. I guess I should confirm it locally and figure out how on the earth that change would have caused this test failure.
Comment 3 Alexey Proskuryakov 2022-02-14 09:55:09 PST
Ryosuke, do you expect to have the time to look into this in near future? If not, we should just revert.
Comment 4 Ryosuke Niwa 2022-02-14 12:23:16 PST
(In reply to Alexey Proskuryakov from comment #3)
> Ryosuke, do you expect to have the time to look into this in near future? If
> not, we should just revert.

Yeah, I'm going to look into this today.
Comment 5 Ryosuke Niwa 2022-02-14 13:07:30 PST
The test passes when ran on its own so it's some kind of inter-test states.
Comment 6 Ryosuke Niwa 2022-02-14 15:27:59 PST
This seems to be an issue with font loading code leaking some kind of inter-test dependency / states. For now, I'm gonna workaround it by forcing a different test options in the test itself to emulate the environment in which test ran prior to r288804
Comment 7 Ryosuke Niwa 2022-02-14 15:28:42 PST
Created attachment 451948 [details]
Patch
Comment 8 Alexey Proskuryakov 2022-02-14 16:33:07 PST
Nice. It this a test harness bug of some kind that the test used to run in this unusual environment prior to r288804? I'm not quite following what changed.

Understood that there is font loading issue too.
Comment 9 Ryosuke Niwa 2022-02-14 16:53:29 PST
(In reply to Alexey Proskuryakov from comment #8)
> Nice. It this a test harness bug of some kind that the test used to run in
> this unusual environment prior to r288804? I'm not quite following what
> changed.

Yeah, so prior to r288804, we had another test which ran immediately before this test that enabled keygen element and that seems to have somehow clear(?) some kind of test interdependent state. I'm using emulating the same effect by forcing ephemeral session  here. It's somewhat of a fragile fix but it's probably more important for this test to get back running instead of root causing whatever font loading issue we may have here.
Comment 10 EWS 2022-02-14 18:17:28 PST
Committed r289787 (247252@main): <https://commits.webkit.org/247252@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 451948 [details].