Bug 23629 - Caret repainting needs to do container-relative repaints
Summary: Caret repainting needs to do container-relative repaints
Status: RESOLVED DUPLICATE of bug 103955
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords:
Depends on:
Blocks: 23359
  Show dependency treegraph
 
Reported: 2009-01-29 15:36 PST by Simon Fraser (smfr)
Modified: 2013-01-30 12:56 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2009-01-29 15:36:59 PST
SelectionController::invalidateCaretRect() does

            view->repaintViewRectangle(caretRepaintRect(), false);
which is not going to work correctly with container-relative repainting.
Comment 1 Arvid Nilsson 2012-10-18 16:27:07 PDT
I think we just hit this:

void RenderLayerCompositor::recursiveRepaintLayerRect(RenderLayer* layer, const
IntRect& rect)
{
    // FIXME: This method does not work correctly with transforms.
    if (layer->isComposited() &&
!layer->backing()->paintsIntoCompositedAncestor())
        layer->setBackingNeedsRepaintInRect(rect);

    ...
}

(RIM PR 216154)
Comment 2 Simon Fraser (smfr) 2012-10-18 16:30:50 PDT
Bug 94985 is related.
Comment 3 Arvid Nilsson 2012-10-18 16:33:01 PDT
(In reply to comment #2)
> Bug 94985 is related.

Thank you, that one looks more specific, it's exactly what we have problem with right now.
Comment 4 Simon Fraser (smfr) 2013-01-30 12:56:51 PST
Bug 103955 fixed this.

*** This bug has been marked as a duplicate of bug 103955 ***