Bug 234790 - HN wasm vector addition benchmark fails to run in safari
Summary: HN wasm vector addition benchmark fails to run in safari
Status: RESOLVED DUPLICATE of bug 222382
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebAssembly (show other bugs)
Version: Safari Technology Preview
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL: https://jott.live/markdown/javascript...
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-01 19:07 PST by Oliver Hunt
Modified: 2022-01-02 00:27 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Hunt 2022-01-01 19:07:31 PST
I saw this benchmark on hacker news, it doesn't run at all in safari and seemingly due to some web assembly error as it isn't simply blocking safari by name:

https://jott.live/markdown/javascript_vector_addition
Comment 1 Yusuke Suzuki 2022-01-02 00:26:54 PST
> Cannot run SIMD on this browser. Please try Chrome or Firefox (or refresh to try again)

Wasm SIMD is not supported in JavaScriptCore yet.
Comment 2 Yusuke Suzuki 2022-01-02 00:27:38 PST

*** This bug has been marked as a duplicate of bug 222382 ***