Bug 234407 - [GTK][WPE] Don't ignore stderr when calling flatpak in update-webkitgtk-libs
Summary: [GTK][WPE] Don't ignore stderr when calling flatpak in update-webkitgtk-libs
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Carlos Alberto Lopez Perez
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-12-16 14:43 PST by Carlos Alberto Lopez Perez
Modified: 2021-12-16 18:16 PST (History)
7 users (show)

See Also:


Attachments
Patch (1.39 KB, patch)
2021-12-16 14:46 PST, Carlos Alberto Lopez Perez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Alberto Lopez Perez 2021-12-16 14:43:38 PST
I had a situation where in an unprivileged LXC container I couldn't run the script update-webkitgtk-libs because flatpak was failing with this error:

bwrap: Can't mount proc on /newroot/proc: Operation not permitted

This was caused by Debian not setting brap as a setuid binary anymore <https://bugs.debian.org/977841> and my LXC unprivileged containers not allowing nesting


The issue here is that it this error was not printed when flatpak was failing, making debugging the issue harder.
I think se should print the stderr
Comment 1 Carlos Alberto Lopez Perez 2021-12-16 14:46:12 PST
Created attachment 447393 [details]
Patch
Comment 2 EWS 2021-12-16 16:03:24 PST
Committed r287162 (245338@main): <https://commits.webkit.org/245338@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 447393 [details].
Comment 3 Radar WebKit Bug Importer 2021-12-16 18:16:36 PST
<rdar://problem/86607693>