Bug 234021 - [Win] WebCore::cfHDropFormat implementation is not CF specific
Summary: [Win] WebCore::cfHDropFormat implementation is not CF specific
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Don Olmstead
URL:
Keywords: InRadar
Depends on:
Blocks: 175336
  Show dependency treegraph
 
Reported: 2021-12-08 10:57 PST by Don Olmstead
Modified: 2021-12-08 12:48 PST (History)
2 users (show)

See Also:


Attachments
Patch (6.97 KB, patch)
2021-12-08 11:05 PST, Don Olmstead
achristensen: review+
achristensen: commit-queue-
Details | Formatted Diff | Diff
Patch (7.62 KB, patch)
2021-12-08 11:28 PST, Don Olmstead
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Don Olmstead 2021-12-08 10:57:33 PST
Drop the USE(CF) guards.
Comment 1 Don Olmstead 2021-12-08 11:05:29 PST
Created attachment 446389 [details]
Patch
Comment 2 Don Olmstead 2021-12-08 11:06:31 PST
Comment on attachment 446389 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=446389&action=review

> Source/WebCore/platform/win/ClipboardUtilitiesWin.cpp:56
> +#if USE(CF)
> +

There is some additional CF specific code in this file that will be removed in a subsequent patch.
Comment 3 Alex Christensen 2021-12-08 11:09:17 PST
Comment on attachment 446389 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=446389&action=review

> Source/WebCore/platform/win/ClipboardUtilitiesWin.cpp:49
>  FORMATETC* cfHDropFormat()

Could we rename these to things like "dropFormat"?

> Source/WebCore/platform/win/ClipboardUtilitiesWin.cpp:737
>  void getCFData(IDataObject* data, FORMATETC* format, Vector<String>& dataStrings)

ditto

> Source/WebCore/platform/win/ClipboardUtilitiesWin.cpp:791
>  void setCFData(IDataObject* data, FORMATETC* format, const Vector<String>& dataStrings)

ditto
Comment 4 Don Olmstead 2021-12-08 11:14:12 PST
Comment on attachment 446389 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=446389&action=review

>> Source/WebCore/platform/win/ClipboardUtilitiesWin.cpp:49
>>  FORMATETC* cfHDropFormat()
> 
> Could we rename these to things like "dropFormat"?

This actually corresponds to https://docs.microsoft.com/en-us/windows/win32/shell/clipboard#cf_hdrop so the name does have a specific meaning to Windows code.
Comment 5 Alex Christensen 2021-12-08 11:15:05 PST
oh, cool.  CFData is not though
Comment 6 Don Olmstead 2021-12-08 11:28:27 PST
Created attachment 446395 [details]
Patch
Comment 7 EWS 2021-12-08 12:47:53 PST
Committed r286708 (244985@main): <https://commits.webkit.org/244985@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 446395 [details].
Comment 8 Radar WebKit Bug Importer 2021-12-08 12:48:43 PST
<rdar://problem/86225180>