RESOLVED FIXED 233891
Remove unneeded virtual allocator methods from Subspace.
https://bugs.webkit.org/show_bug.cgi?id=233891
Summary Remove unneeded virtual allocator methods from Subspace.
Mark Lam
Reported 2021-12-06 12:27:39 PST
Since the virtual allocate() and allocateFor() methods are now deleted, we can also rename the inline allocateNonVirtual() and allocatorForNonVirtual() methods to simply allocate() and allocateFor(). Similarly, rename allocatorForNonVirtualConcurrently() to allocatorForConcurrently(). There are 2 places that still invokes the non-inline version of CompleteSubspace::allocatorFor(). For this reason, we introduce a CompleteSubsace::allocatorForNonInline() to keep the linkage the same. There's a chance that the compiler/linker may already inline the method in 1 or both of these places, but we'll offer allocatorForNonInline() to keep the code expressing the same thing and let the compiler/linker decide whether to inline it or not just as before. This is purely a re-factoring patch. There are no behavior changes, except for the removal of those 2 entries from the vtbls.
Attachments
proposed patch. (38.27 KB, patch)
2021-12-06 12:32 PST, Mark Lam
ysuzuki: review+
ews-feeder: commit-queue-
Radar WebKit Bug Importer
Comment 1 2021-12-06 12:28:32 PST
Mark Lam
Comment 2 2021-12-06 12:32:16 PST
Created attachment 446068 [details] proposed patch.
Yusuke Suzuki
Comment 3 2021-12-06 12:43:14 PST
Comment on attachment 446068 [details] proposed patch. r=me
Mark Lam
Comment 4 2021-12-06 14:52:48 PST
Thanks for the review. Landed in r286572: <http://trac.webkit.org/r286572>.
Note You need to log in before you can comment on or make changes to this bug.