Bug 233429 - Scrolling gets stuck on gatesnotes.com on iPad
Summary: Scrolling gets stuck on gatesnotes.com on iPad
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Scrolling (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-11-22 11:15 PST by Jon Lee
Modified: 2022-02-22 15:28 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Lee 2021-11-22 11:15:01 PST
https://www.gatesnotes.com/About-Bill-Gates/Holiday-Books-2021

On iPad, Scrolling gets stuck. There is sometimes no momentum. Sometimes I can’t scroll the page at on. It seems all right on iPhone.
Comment 1 Jon Lee 2021-11-22 11:18:01 PST
I feel like the experience is worse using the trackpad accessory with the iPad, but it’s plenty bad with just finger scrolling.
Comment 2 Radar WebKit Bug Importer 2021-11-29 11:15:24 PST
<rdar://problem/85826265>
Comment 3 Simon Fraser (smfr) 2022-02-22 14:47:44 PST
The page scrolls mostly fine for me. At one point I got an overlay; if you have a content blocker that hides this, it may still result in blocked scrolling.

There is a period where pages tiles stop painting, which looks like a busy main web content thread.
Comment 4 Simon Fraser (smfr) 2022-02-22 14:50:55 PST
There's a perdiod of about 1.5s where the page finishes an XHR and spends all that time running script.
Comment 5 Jon Lee 2022-02-22 15:28:21 PST
I no longer can reproduce this.