Bug 23329 - PluginData::initPlugins() is always called even when plugins are disabled
Summary: PluginData::initPlugins() is always called even when plugins are disabled
Status: RESOLVED DUPLICATE of bug 22452
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Linux
: P2 Normal
Assignee: Ariya Hidayat
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-14 11:25 PST by Ariya Hidayat
Modified: 2009-01-16 07:18 PST (History)
0 users

See Also:


Attachments
Patch to fix the problem (1.88 KB, patch)
2009-01-14 11:26 PST, Ariya Hidayat
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ariya Hidayat 2009-01-14 11:25:25 PST
Apparently PluginData::initPlugins(), which potentially initializes the plugin database, will be still invoked even when plugins are disabled.
Comment 1 Ariya Hidayat 2009-01-14 11:26:30 PST
Created attachment 26722 [details]
Patch to fix the problem
Comment 2 Ariya Hidayat 2009-01-15 08:37:59 PST

*** This bug has been marked as a duplicate of 22452 ***