Bug 233064 - Stop statically declaring various UIFoundation constants in NSAttributedStringSPI.h
Summary: Stop statically declaring various UIFoundation constants in NSAttributedStrin...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Wenson Hsieh
URL:
Keywords: InRadar
: 233139 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-11-12 13:19 PST by Wenson Hsieh
Modified: 2021-11-15 11:33 PST (History)
4 users (show)

See Also:


Attachments
For EWS (4.60 KB, patch)
2021-11-12 13:24 PST, Wenson Hsieh
no flags Details | Formatted Diff | Diff
Followup (4.59 KB, patch)
2021-11-14 16:51 PST, Wenson Hsieh
ews-feeder: commit-queue-
Details | Formatted Diff | Diff
Followup (fix iOS family build?) (4.63 KB, patch)
2021-11-14 16:59 PST, Wenson Hsieh
no flags Details | Formatted Diff | Diff
Followup v2 (4.96 KB, patch)
2021-11-14 17:15 PST, Wenson Hsieh
no flags Details | Formatted Diff | Diff
Followup v2 (4.96 KB, patch)
2021-11-15 09:12 PST, Wenson Hsieh
no flags Details | Formatted Diff | Diff
Followup v3 (4.95 KB, patch)
2021-11-15 09:13 PST, Wenson Hsieh
no flags Details | Formatted Diff | Diff
Followup v4 (4.99 KB, patch)
2021-11-15 09:27 PST, Wenson Hsieh
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Wenson Hsieh 2021-11-12 13:19:15 PST
rdar://85341122
Comment 1 Wenson Hsieh 2021-11-12 13:24:34 PST
Created attachment 444102 [details]
For EWS
Comment 2 EWS 2021-11-12 14:47:29 PST
Committed r285744 (244203@main): <https://commits.webkit.org/244203@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 444102 [details].
Comment 3 Radar WebKit Bug Importer 2021-11-12 14:48:21 PST Comment hidden (obsolete)
Comment 4 Wenson Hsieh 2021-11-14 16:51:09 PST
Reopening to attach new patch.
Comment 5 Wenson Hsieh 2021-11-14 16:51:10 PST Comment hidden (obsolete)
Comment 6 Wenson Hsieh 2021-11-14 16:59:51 PST Comment hidden (obsolete)
Comment 7 Wenson Hsieh 2021-11-14 17:15:28 PST Comment hidden (obsolete)
Comment 8 Wenson Hsieh 2021-11-15 09:12:02 PST Comment hidden (obsolete)
Comment 9 Wenson Hsieh 2021-11-15 09:13:18 PST Comment hidden (obsolete)
Comment 10 Wenson Hsieh 2021-11-15 09:27:20 PST
Created attachment 444266 [details]
Followup v4
Comment 11 EWS 2021-11-15 10:36:57 PST
Committed r285811 (244255@main): <https://commits.webkit.org/244255@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 444266 [details].
Comment 12 David Kilzer (:ddkilzer) 2021-11-15 11:33:56 PST
*** Bug 233139 has been marked as a duplicate of this bug. ***