Bug 232815 - Mac Kernel Panic
Summary: Mac Kernel Panic
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: Safari 14
Hardware: Mac (Apple Silicon) macOS 11
: P2 Critical
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-08 05:55 PST by Jinkyu Kim
Modified: 2021-11-08 10:08 PST (History)
1 user (show)

See Also:


Attachments
kernel panic webkit (15.15 KB, text/plain)
2021-11-08 05:55 PST, Jinkyu Kim
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jinkyu Kim 2021-11-08 05:55:29 PST
Created attachment 443537 [details]
kernel panic webkit

Running safari in a situation that occupies a lot of CPU/GPU such as WindowServer and xcode build causes frequent kernel panic.
I have found that kernel panic does not appear in other browsers that can disable GPU hardware acceleration, 
but since Catalina, Safari no longer provides GPU hardware acceleration disable.

I attached logs of kernel panic below.
Thanks
Comment 1 Alexey Proskuryakov 2021-11-08 10:08:48 PST
An issue that resulted in such kernel panics was fixed in an underlying macOS component in macOS Monterey (cf. rdar://80727239 for Apple employees).

If this continues to reproduce, please file a report at <https://feedbackassistant.apple.com>. It would be very valuable to include a kernel core dump in the report.