Bug 232691 - REGRESSION(r284883): load event of link element is fired repeatedly on https://cmake.org/
Summary: REGRESSION(r284883): load event of link element is fired repeatedly on https:...
Status: RESOLVED DUPLICATE of bug 232309
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-03 17:39 PDT by Fujii Hironori
Modified: 2021-11-08 11:59 PST (History)
1 user (show)

See Also:


Attachments
reduced content (147 bytes, text/html)
2021-11-03 17:40 PDT, Fujii Hironori
no flags Details
reduced content with log (178 bytes, text/html)
2021-11-03 18:36 PDT, Fujii Hironori
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fujii Hironori 2021-11-03 17:39:46 PDT
[WinCairo] high CPU usage on https://cmake.org/

1. Start Windows Task Manager
2. Start WinCairo MiniBrowser
3. Go to https://cmake.org/
4. CPU usage of WebKitWebProcess.exe is high for a while

Mac port doesn't have this problem.
Comment 1 Fujii Hironori 2021-11-03 17:40:10 PDT
Created attachment 443261 [details]
reduced content
Comment 2 Fujii Hironori 2021-11-03 18:36:44 PDT
Created attachment 443266 [details]
reduced content with log

onload is fired repeatedly.
Comment 3 Fujii Hironori 2021-11-03 19:18:27 PDT
Reverting r284883 fixes the problem.
Comment 4 Fujii Hironori 2021-11-04 00:48:24 PDT
Mac port also has this problem.
Comment 5 Fujii Hironori 2021-11-04 13:13:46 PDT
(In reply to Fujii Hironori from comment #2)
> Created attachment 443266 [details]
> reduced content with log
> 
> onload is fired repeatedly.

In this test case,
Chrome dispatches only once.
Firefox dispatches only twice.
Safari dispatches infinitely.
Comment 6 Fujii Hironori 2021-11-08 11:59:16 PST
r285417 reverted r284883. Closed.

*** This bug has been marked as a duplicate of bug 232309 ***