Bug 232575 - Make ScrollGranularity an enum class
Summary: Make ScrollGranularity an enum class
Status: RESOLVED DUPLICATE of bug 232641
Alias: None
Product: WebKit
Classification: Unclassified
Component: Scrolling (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nikos Mouchtaris
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-11-01 12:38 PDT by Nikos Mouchtaris
Modified: 2021-11-09 17:39 PST (History)
30 users (show)

See Also:


Attachments
Patch (98.73 KB, patch)
2021-11-01 12:40 PDT, Nikos Mouchtaris
ews-feeder: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nikos Mouchtaris 2021-11-01 12:38:20 PDT
Make ScrollElasticity, ScrollbarOrientation, ScrollbarMode, ScrollGranularity enum classes
Comment 1 Nikos Mouchtaris 2021-11-01 12:40:54 PDT
Created attachment 443001 [details]
Patch
Comment 2 Tim Nguyen (:ntim) 2021-11-06 10:00:41 PDT
Looks like only ScrollGranularity is left.
Comment 3 Radar WebKit Bug Importer 2021-11-08 11:39:20 PST
<rdar://problem/85165669>
Comment 4 Cameron McCormack (:heycam) 2021-11-09 17:38:51 PST
ScrollGranularity is being handled in bug 232641; duping forward.

*** This bug has been marked as a duplicate of bug 232641 ***