Bug 232502 - Monterey crash in WebKit::DisplayLink::addObserver
Summary: Monterey crash in WebKit::DisplayLink::addObserver
Status: RESOLVED DUPLICATE of bug 230917
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: Other
Hardware: Mac (Intel) Other
: P2 Normal
Assignee: Nobody
Depends on:
Reported: 2021-10-29 11:34 PDT by Brad Andalman
Modified: 2021-11-03 11:56 PDT (History)
2 users (show)

See Also:

Text contained in the Apple crash dialog (43.49 KB, text/rtf)
2021-10-29 11:34 PDT, Brad Andalman
no flags Details
Text contained in the Apple crash dialog (second time) (40.75 KB, text/rtf)
2021-10-29 11:34 PDT, Brad Andalman
no flags Details
Crash in slightly different location (forgot to grab text, but found this screenshot) (1.11 MB, image/png)
2021-10-29 11:35 PDT, Brad Andalman
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brad Andalman 2021-10-29 11:34:19 PDT
Created attachment 442847 [details]
Text contained in the Apple crash dialog

OK. This is a weird one.

We have an application, Vellum, that uses WKWebViews on Monterey to generate a PDF. I hit some very strange crashes in WebKit::DisplayLink::addObserver (see attached stack traces) as well as WebKit::DisplayLink::setPreferredFramesPerSecond (see attached screenshot – forgot to copy the text). 

Here’s the weird part: I could only get these crashes to occur when playing something via Spotify (!). In particular, I found that it happens when I am playing Shackleton’s “Something Tells Me / Pour Out Like Water” track off of “Departing Like Rivers” album (!!!). 

I tried other tracks on other albums, and couldn’t get it to happen. Now, I don’t think that this is Shackleton-specific (though wouldn’t that be a great bug?!). But maybe the fact that this track is 12 minutes long is affecting something? Why Spotify should be affecting OUR application, though, is a mystery.

Since I hit these crashes in the Monterey Beta, we’ve noticed similar stack traces in our crash reporting database. So, this means that users who are now upgrading to Monterey are hitting this too.

I haven’t tried to reproduce this yet via a smaller test app. If you are going to try to reproduce this issue, please let me know and I can provide you with an evaluation license so you can generate via Vellum. Here’s where you can download our application:

It’s free to download, but you won’t be able to generate books without a license.
Comment 1 Brad Andalman 2021-10-29 11:34:51 PDT
Created attachment 442848 [details]
Text contained in the Apple crash dialog (second time)
Comment 2 Brad Andalman 2021-10-29 11:35:24 PDT
Created attachment 442849 [details]
Crash in slightly different location (forgot to grab text, but found this screenshot)
Comment 3 Sam Sneddon [:gsnedders] 2021-10-29 13:29:16 PDT
Simon/Tim: pretty sure this is a dupe of this? Plz shout at me if I'm wrong.

*** This bug has been marked as a duplicate of bug 230917 ***
Comment 4 Brad Andalman 2021-10-30 10:30:44 PDT
I really hope this is our bug, and am happy to see that (if it is) it has already been fixed.

That said, this bug is affecting some of our uses pretty significantly right now. Is there anything we can do on our end that makes it less likely to hit this bug?
Comment 5 Simon Fraser (smfr) 2021-10-30 10:52:54 PDT
Sadly there isn't any workaround.
Comment 6 Brad Andalman 2021-10-30 11:40:24 PDT
Bummer. I know it's unlikely...but is there any chance we might known when this fix will be incorporated into Monterey?
Comment 7 Brad Andalman 2021-11-03 11:56:49 PDT
Also, in looking through our 120+ crashes, we've noticed that the crash only occurs in Monterey on NON-ARM chips. That is, we haven't seen any crashes on M1 machines.

Figured I should update this bug, just in case that changes the likelihood that this bug is the same as the one its duped to.