Bug 23249 - display does not jump horizontally to a name anchor
Summary: display does not jump horizontally to a name anchor
Status: RESOLVED DUPLICATE of bug 116046
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-12 05:49 PST by j-k-a-p
Modified: 2013-09-30 11:47 PDT (History)
1 user (show)

See Also:


Attachments
very broad page, having an anchor (probably) outside the window. (1.04 KB, text/html)
2009-01-14 13:27 PST, j-k-a-p
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description j-k-a-p 2009-01-12 05:49:22 PST
With a page broader than the current window and containing a name anchor like <a name="expecttoseethisanchor"> (e.g. attached to a location somewhere in a paragraph in the right corner of a table), calling it's URL with one of those anchors like 
http://www.mysite.xy/broadpage.html#expecttoseethisanchor
will just move the page vertically, not horizontally to that anchor.
If the anchor is outside of the current view, this behaviour is disturbing and annoying.

(Apple's Safari ONCE had this correct behaviour (as the only browser, if I remember), then lost part of this functionality (the anchor only appeared in the top right corner with a left-to-right script where it once appeared in the top left corner, as it should) but also Safari it dropped some time ago.)

I would expect a jump both vertical and horizontal, at least if the anchor position is outside the current window. The jump could be reduced to a move sufficient to completely display the paragraph or a different entity, like a table cell or else.

So, the position of the anchor should also represent the script direction (left-to-right or right-to-left) of the surrounding context.

Sorry, English is not my mother tongue.
Comment 1 j-k-a-p 2009-01-12 10:44:13 PST
Firefox 3.0.5 has the intermediate behaviour, still wrong:
The anchor appears in the top-right corner (with a regular left-to-right script), so the text is still outside the window.
Comment 2 j-k-a-p 2009-01-14 13:27:13 PST
Created attachment 26727 [details]
very broad page, having an anchor (probably) outside the window.
Comment 3 James Craig 2013-09-30 11:47:17 PDT
New repro link.
https://bug-23249-attachments.webkit.org/attachment.cgi?id=26727#expecttoseethisanchor

Duping to bug 116046 which covers fragment ID links in more detail.

*** This bug has been marked as a duplicate of bug 116046 ***