Bug 23192 - Large tables cause huge memory consumption and leaks
Summary: Large tables cause huge memory consumption and leaks
Status: RESOLVED DUPLICATE of bug 23193
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tables (show other bugs)
Version: 525.x (Safari 3.2)
Hardware: Macintosh OS X 10.5
: P2 Major
Assignee: Nobody
URL: http://www.zdziarski.com/test/temp.html
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-08 13:07 PST by Jonathan Zdziarski
Modified: 2009-01-08 16:01 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Zdziarski 2009-01-08 13:07:32 PST
I've found creating tables with 1000, 5000, 10000+ rows causes significant memory consumption and leaks. The URL provided is a 1.6MB file with approximately 6000 rows. Both Safari desktop and Safari on the iPhone grow over 40-50MB to render the page. This causes Safari on the iPhone to be killed by SpringBoard for using too much memory. Smaller pages of say, 1000 rows, appear to be creating memory leaks I cannot trace to my own code. Even after a UIWebView object is destroyed, it appears as though several MB of memory from the underlying objects are never released, meaning Safari on the iPhone will be killed off if the same 1000 row table is displayed more than a few times.
Comment 1 Mark Rowe (bdash) 2009-01-08 16:01:02 PST

*** This bug has been marked as a duplicate of 23193 ***