Bug 23188 - Need to cleanup all the names of state functions in AnimationBase
Summary: Need to cleanup all the names of state functions in AnimationBase
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.5
: P2 Normal
Assignee: Chris Marrin
URL:
Keywords:
: 23513 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-08 10:09 PST by Chris Marrin
Modified: 2012-12-12 06:11 PST (History)
3 users (show)

See Also:


Attachments
Patch to clean up Animation (21.32 KB, patch)
2009-02-12 12:21 PST, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Same patch with no license changes. (8.43 KB, patch)
2009-02-12 12:35 PST, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Marrin 2009-01-08 10:09:18 PST
There are many functions in AnimationBase (like isNew() and postactive()) which tell you which state or states the state machine is in. But they are really confusing, both in how they are named and what they actually mean. These should all be cleaned up
Comment 1 Simon Fraser (smfr) 2009-01-08 10:20:04 PST
Also willNeedService() needs a better name.
Comment 2 Simon Fraser (smfr) 2009-02-03 17:50:42 PST
Also:

In Animation:

    bool direction() const { return m_direction; }
This needs to have an enum.
    int iterationCount() const { return m_iterationCount; }
This needs a constant for the magic "-1" value.
Comment 3 Simon Fraser (smfr) 2009-02-03 17:50:47 PST
*** Bug 23513 has been marked as a duplicate of this bug. ***
Comment 4 Simon Fraser (smfr) 2009-02-12 12:21:13 PST
Created attachment 27617 [details]
Patch to clean up Animation
Comment 5 Simon Fraser (smfr) 2009-02-12 12:35:12 PST
Created attachment 27620 [details]
Same patch with no license changes.
Comment 6 Dave Hyatt 2009-02-12 12:35:45 PST
Comment on attachment 27620 [details]
Same patch with no license changes.

r=me
Comment 7 Simon Fraser (smfr) 2009-02-12 12:47:43 PST
Comment on attachment 27620 [details]
Same patch with no license changes.

Landed:
Committing to http://svn.webkit.org/repository/webkit/trunk ...
	M	WebCore/ChangeLog
	M	WebCore/css/CSSComputedStyleDeclaration.cpp
	M	WebCore/platform/animation/Animation.cpp
	M	WebCore/platform/animation/Animation.h
	M	WebCore/platform/graphics/mac/GraphicsLayerCA.mm
Committed r40923
Comment 8 Brent Fulgham 2009-02-13 11:41:53 PST
Closing bug as it has been committed to the archive.
Comment 9 Simon Fraser (smfr) 2009-02-13 11:49:12 PST
There's more cleanup to do (specifically, willGetService()).
Comment 10 Eric Seidel (no email) 2009-04-29 14:56:25 PDT
Comment on attachment 27620 [details]
Same patch with no license changes.

Historically we've tried for one-bug-per-change.  But if you'd like to leave this open, we should at least clear the review flag to remove it from the commit queue.  (Eventually we should just fix the commit queue query).
Comment 11 Alexis Menard (darktears) 2012-12-12 06:11:58 PST
I think all the cleanup landed. I can't find any trace of the old confusing names.