Bug 231755 - [iOS] Paint <datalist> indicator in RenderTheme
Summary: [iOS] Paint <datalist> indicator in RenderTheme
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Aditya Keerthi
URL:
Keywords: InRadar
Depends on:
Blocks: 231762
  Show dependency treegraph
 
Reported: 2021-10-14 12:09 PDT by Aditya Keerthi
Modified: 2021-10-14 18:58 PDT (History)
12 users (show)

See Also:


Attachments
Patch (15.72 KB, patch)
2021-10-14 12:20 PDT, Aditya Keerthi
no flags Details | Formatted Diff | Diff
Patch (15.76 KB, patch)
2021-10-14 12:26 PDT, Aditya Keerthi
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Aditya Keerthi 2021-10-14 12:09:52 PDT
...
Comment 1 Aditya Keerthi 2021-10-14 12:10:09 PDT
rdar://84261604
Comment 2 Aditya Keerthi 2021-10-14 12:20:12 PDT
Created attachment 441253 [details]
Patch
Comment 3 Aditya Keerthi 2021-10-14 12:26:07 PDT
Created attachment 441255 [details]
Patch
Comment 4 Tim Horton 2021-10-14 12:32:56 PDT
Comment on attachment 441255 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=441255&action=review

> Source/WebCore/rendering/style/RenderStyle.h:1477
> +    void setHasExplicitlyClearedContent(bool v) { m_nonInheritedFlags.hasExplicitlyClearedContent = v; }

`v` is not my favorite name for a parameter
Comment 5 Aditya Keerthi 2021-10-14 12:34:49 PDT
(In reply to Tim Horton from comment #4)
> Comment on attachment 441255 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=441255&action=review
> 
> > Source/WebCore/rendering/style/RenderStyle.h:1477
> > +    void setHasExplicitlyClearedContent(bool v) { m_nonInheritedFlags.hasExplicitlyClearedContent = v; }
> 
> `v` is not my favorite name for a parameter

I was just following the naming convention in the rest of this class :)
Comment 6 Tim Horton 2021-10-14 12:45:27 PDT
(In reply to Aditya Keerthi from comment #5)
> (In reply to Tim Horton from comment #4)
> > Comment on attachment 441255 [details]
> > Patch
> > 
> > View in context:
> > https://bugs.webkit.org/attachment.cgi?id=441255&action=review
> > 
> > > Source/WebCore/rendering/style/RenderStyle.h:1477
> > > +    void setHasExplicitlyClearedContent(bool v) { m_nonInheritedFlags.hasExplicitlyClearedContent = v; }
> > 
> > `v` is not my favorite name for a parameter
> 
> I was just following the naming convention in the rest of this class :)

Ah, I thought that might be but I couldn't expand the context for some reason! Fine :D
Comment 7 EWS 2021-10-14 18:58:32 PDT
Committed r284225 (243034@main): <https://commits.webkit.org/243034@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 441255 [details].