Bug 231309 - Add AdAttributionDaemon plist on iOS
Summary: Add AdAttributionDaemon plist on iOS
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alex Christensen
URL:
Keywords: InRadar
: 231817 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-10-06 10:44 PDT by Alex Christensen
Modified: 2021-10-15 12:14 PDT (History)
7 users (show)

See Also:


Attachments
Patch (10.45 KB, patch)
2021-10-06 10:45 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (11.83 KB, patch)
2021-10-06 11:26 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (11.79 KB, patch)
2021-10-06 13:24 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (12.48 KB, patch)
2021-10-14 20:14 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Christensen 2021-10-06 10:44:21 PDT
Add AdAttributionDaemon plist on iOS
Comment 1 Alex Christensen 2021-10-06 10:45:24 PDT
Created attachment 440386 [details]
Patch
Comment 2 Alex Christensen 2021-10-06 11:26:09 PDT
Created attachment 440396 [details]
Patch
Comment 3 Alex Christensen 2021-10-06 13:24:16 PDT
Created attachment 440427 [details]
Patch
Comment 4 Alex Christensen 2021-10-06 17:22:30 PDT
I verified that this puts the plist in the correct location and it results in the daemon starting.  This should be ready to review.
The daemon currently uses too much memory, so we'll need a separate bug to reduce the memory and land that first.
Comment 5 Radar WebKit Bug Importer 2021-10-13 10:45:15 PDT
<rdar://problem/84205891>
Comment 6 Alex Christensen 2021-10-14 20:14:38 PDT
Created attachment 441325 [details]
Patch
Comment 7 John Wilander 2021-10-14 20:28:57 PDT
Comment on attachment 441325 [details]
Patch

This is not my area of expertise. Please check the GTK bots here before landing. Also, please monitor bots to make sure we don't break a build or test suite somewhere once this lands.
Comment 8 EWS 2021-10-14 21:47:54 PDT
Committed r284233 (243042@main): <https://commits.webkit.org/243042@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 441325 [details].
Comment 9 David Kilzer (:ddkilzer) 2021-10-15 12:14:20 PDT
*** Bug 231817 has been marked as a duplicate of this bug. ***