Bug 230525 - [MacOS] Safari 15 beta fails to load pages with Babylon.js or Sketchfab on Big Sur
Summary: [MacOS] Safari 15 beta fails to load pages with Babylon.js or Sketchfab on Bi...
Status: RESOLVED DUPLICATE of bug 229309
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: Other
Hardware: Mac (Intel) macOS 11
: P2 Critical
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-20 17:14 PDT by Darragh Burke
Modified: 2021-09-21 02:28 PDT (History)
3 users (show)

See Also:


Attachments
Babylon Playground and Sketchfab crashing (19.36 MB, video/quicktime)
2021-09-20 17:14 PDT, Darragh Burke
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Darragh Burke 2021-09-20 17:14:45 PDT
Created attachment 438758 [details]
Babylon Playground and Sketchfab crashing

Overview
Opening sketchfab.com, playground.babylonjs.com, or any page using a Babylon.js engine causes the page to repeatedly reload before settling on a grey screen saying "A problem repeatedly occurred". There is no output in the console to indicate the reason for the problem.

We have narrowed the crash down to calling getContext() with the xrCompatible context attribute set to true. If this flag is false, the page does not crash.

Steps to Reproduce

1) Navigate to http://playground.babylonjs.com or http://sketchfab.com.
2) Wait for the page to reload a few times and then die.

Actual Results:
The page attempts to reload several times before giving up and saying that a problem occurred.

Expected Results:
The web page should load and display the normal 3D content, as it does in earlier versions of Safari and other browsers.

Build Date & Hardware : Version 15.0 (16612.1.29.41.4, 16612) on MacBook Pro (15-inch, 2017), macOS Big Sur Version 11.6.

Additional Builds and Platforms:
Release 131 of Safari Technology Preview does not appear to have this issue.

Additional Information:
Comment 1 Kimmo Kinnunen 2021-09-21 02:22:46 PDT
Thanks for the report! This is already fixed in bug 229309
Comment 2 Myles C. Maxfield 2021-09-21 02:27:53 PDT

*** This bug has been marked as a duplicate of bug 229309 ***