Bug 230106 - Safari Transitions No Longer Convert Between px and %
Summary: Safari Transitions No Longer Convert Between px and %
Status: RESOLVED DUPLICATE of bug 228811
Alias: None
Product: WebKit
Classification: Unclassified
Component: Animations (show other bugs)
Version: Other
Hardware: iPhone / iPad Other
: P2 Normal
Assignee: Antoine Quint
Keywords: InRadar
Depends on:
Reported: 2021-09-09 10:04 PDT by Matthew Pringle
Modified: 2021-09-10 02:13 PDT (History)
6 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Pringle 2021-09-09 10:04:13 PDT
This is iOS 15 beta 8 Safari

This CSS code previously worked, where adding a class to start the transition would animate from 100% to 0px.

transition: top 0.25s;
top: 100%;
html.active {
    top: 0px;

The above has stopped working in iOS 15 Safari Beta 8, but the below works, replacing the px with %

transition: top 0.25s;
top: 100%;
html.active {
    top: 0%;
Comment 1 Radar WebKit Bug Importer 2021-09-09 10:30:38 PDT
Comment 2 Antoine Quint 2021-09-09 11:45:01 PDT
Matthew, when you say "stopped working in iOS 15 Safari Beta 8", do you mean it worked in previous beta seeds of iOS 15, or just iOS 14? Thanks.
Comment 3 Matthew Pringle 2021-09-09 11:50:32 PDT
Stopped working between iOS 14 and iOS 15 beta 8. It was not tested in any other betas.
Comment 4 Matthew Pringle 2021-09-09 12:15:15 PDT
iOS 14.4 to be exact
Comment 5 Antoine Quint 2021-09-09 12:18:55 PDT
Oh, I think this is a duplicate of bug 228811.
Comment 6 Antoine Quint 2021-09-09 12:25:08 PDT

*** This bug has been marked as a duplicate of bug 228811 ***
Comment 7 Matthew Pringle 2021-09-09 12:26:55 PDT
I will check tomorrow as my app also animates widths on some progress bars and so should fail on those aswell.

Tested in iOS back to 12.4 and it is fine in those versions.
Comment 8 Matthew Pringle 2021-09-10 02:13:47 PDT
The other transitions work fine in iOS 15 beta 8 and so yes it seems to be a duplicate of https://bugs.webkit.org/show_bug.cgi?id=228811

Thanks for the help