Bug 230057 - [GStreamer] Green screen instead of playing video
Summary: [GStreamer] Green screen instead of playing video
Status: RESOLVED MOVED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: Other
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2021-09-08 11:51 PDT by Christian Stadelmann
Modified: 2021-09-09 07:09 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Stadelmann 2021-09-08 11:51:10 PDT
Steps to reproduce:
1. Start epiphany
2. browse any website with video
3. start video

What should happen:
Play video. If it cannot be done using hardware acceleration, use software video decoding instead. If that is also not possible, show an error message.

What happens:
Green screen instead of video. Video stops after some time.

Example output on command line:
```
$ LC_ALL=C epiphany https://winfuture.de/videos/Hardware/Fairphone-3-im-Hands-On-Transparentes-fair-gebautes-Smartphone-20630.html
failed to open /usr/lib64/dri/hybrid_drv_video.so
Not using hybrid_drv_video.so
failed to open /usr/lib64/dri/hybrid_drv_video.so
Not using hybrid_drv_video.so
failed to open /usr/lib64/dri/hybrid_drv_video.so
Not using hybrid_drv_video.so

** (epiphany:252407): WARNING **: 19:29:51.802: GDK is not able to create a GL context, falling back to glReadPixels (slow!): Unable to create a GL context
```
(Note that I don't have a hybrid GPU system, only an Intel iGPU)

Software version info:
epiphany-40.3-1.fc34.x86_64
webkit2gtk3-2.32.3-1.fc34.x86_64
glib2-2.68.4-1.fc34.x86_64
gtk3-3.24.30-1.fc34.x86_64
gstreamer1-1.19.1-2.1.18.4.fc34.x86_64
gstreamer1-vaapi-1.19.1-2.1.18.4.fc34.x86_64
gstreamer1-libav-1.18.4-3.fc34.x86_64
libva-2.11.0-1.fc34.x86_64
libva-intel-driver-2.4.1-5.fc34.x86_64

I am willing to provide more debugging info but I don't know where to start debugging.

Note: This issue was first reported on https://gitlab.gnome.org/GNOME/epiphany/-/issues/1594 and put here due to a hint by Michael Catanzaro.
Comment 1 Christian Stadelmann 2021-09-08 11:55:12 PDT
Additional notes:
This is in a GNOME Wayland session.
DConf org.gnome.Epiphany.web hardware-acceleration-policy is 'on-demand'
Comment 2 Michael Catanzaro 2021-09-08 13:34:35 PDT
By coincidence, somebody else ran into the exact same problem today, and fixed it by uninstalling gstreamer1-vaapi. That will probably fix it for you. (Even if we hadn't dealt with the same problem earlier today, uninstalling gstreamer1-vaapi would be my normal first suggestion.)

If that fixes your problem -- it probably will -- then I'm afraid we'll need to yet again ping-pong you to their bug tracker: https://gitlab.freedesktop.org/gstreamer/gstreamer-vaapi/issues/.

> DConf org.gnome.Epiphany.web hardware-acceleration-policy is 'on-demand'

Note this setting controls web rendering only. It's unrelated to hardware-accelerated video decoding.
Comment 3 Christian Stadelmann 2021-09-08 22:04:42 PDT
(In reply to Michael Catanzaro from comment #2)
> By coincidence, somebody else ran into the exact same problem today, and
> fixed it by uninstalling gstreamer1-vaapi.

I've heard that before and probably have even done that as a workaround before. Thanks for the reminder. And yes, playing the video after uninstalling gstreamer1-vaapi works (same command line as before):

```
$ LC_ALL=C epiphany https://winfuture.de/videos/Hardware/Fairphone-3-im-Hands-On-Transparentes-fair-gebautes-Smartphone-20630.html

** (epiphany:263650): WARNING **: 06:47:12.362: GDK is not able to create a GL context, falling back to glReadPixels (slow!): Unable to create a GL context
```

> If that fixes your problem -- it probably will -- then I'm afraid we'll need
> to yet again ping-pong you to their bug tracker:
> https://gitlab.freedesktop.org/gstreamer/gstreamer-vaapi/issues/.

Done: https://gitlab.freedesktop.org/gstreamer/gstreamer-vaapi/-/issues/312

Shall I mark this bug report here as "resolved | moved"?

> > DConf org.gnome.Epiphany.web hardware-acceleration-policy is 'on-demand'
> 
> Note this setting controls web rendering only. It's unrelated to
> hardware-accelerated video decoding.

Thanks for explaination!
Comment 4 Michael Catanzaro 2021-09-09 07:09:55 PDT
> Shall I mark this bug report here as "resolved | moved"?

Yes, but I'll do that now.