Bug 229884 - [ JSC Catalina Debug ] testapi is failing on the Apple-Catalina-LLINT-CLoop-BuildAndTest bot
Summary: [ JSC Catalina Debug ] testapi is failing on the Apple-Catalina-LLINT-CLoop-B...
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-09-03 12:29 PDT by Robert Jenner
Modified: 2021-09-05 14:45 PDT (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Jenner 2021-09-03 12:29:31 PDT
testapi appears to be failing on the Apple-Catalina-LLINT-CLoop-BuildAndTest bot.

HISTORY:
https://results.webkit.org/?suite=javascriptcore-tests&test=testapi

BUILD:
https://build.webkit.org/#/builders/39/builds/5570

It is a flaky failure technically. But it is a fairly consistent failure having failed more frequently than it passes. It also appears to have been in this state since it started running on this queue, starting at r280283:
https://trac.webkit.org/changeset/280283/webkit
Comment 1 Radar WebKit Bug Importer 2021-09-03 12:29:54 PDT
<rdar://problem/82734446>
Comment 2 Robert Jenner 2021-09-03 12:35:19 PDT
I wouldn't classify this as a regression, being that it appears to have been problematic since it started running on that queue.
Comment 3 Ryan Haddad 2021-09-03 14:41:42 PDT
The following message appears 6 times during the failing testapi runs:

FAILED MultithreadedMultiVMExecutionTest: script eval
Comment 4 Alexey Proskuryakov 2021-09-05 14:45:58 PDT
It's usually passing on MacPro6,1, and usually failing on Macmini8,1.