Bug 229622 - Rename enums in CSSUnitType to CamelCase and remove CSS_ prefix
Summary: Rename enums in CSSUnitType to CamelCase and remove CSS_ prefix
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kiet Ho
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-08-27 12:17 PDT by Kiet Ho
Modified: 2022-10-09 06:11 PDT (History)
24 users (show)

See Also:


Attachments
Patch (350.41 KB, patch)
2021-08-27 12:34 PDT, Kiet Ho
no flags Details | Formatted Diff | Diff
Patch (350.30 KB, patch)
2021-08-27 14:29 PDT, Kiet Ho
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kiet Ho 2021-08-27 12:17:54 PDT
Rename enums in CSSUnitType to CamelCase and remove CSS_ prefix.

Most renames follow the format CSSUnitType::CSS_XXX_YYY => CSSUnitType::XxxYyy except for:
* If there exists a method CSSPrimitiveValue::IsXXXX(), then it's renamed to CssUnitType::XXXX instead. For example, CSS_VW is renamed to ViewportPercentageWidth because of CSSPrimitiveValue::IsViewportPercentageWidth()
* CSS_S is renamed to Second

Feel free to comment if you think an enum should be renamed to something else.
Comment 1 Kiet Ho 2021-08-27 12:34:31 PDT
Created attachment 436657 [details]
Patch
Comment 2 Kiet Ho 2021-08-27 14:29:12 PDT
Created attachment 436675 [details]
Patch
Comment 3 Simon Fraser (smfr) 2021-08-27 14:35:54 PDT
Comment on attachment 436675 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=436675&action=review

> Source/WebCore/css/CSSUnits.h:64
> +    DotsPerInch = 31,
> +    DotsPerCentimeter = 32,

We use Cm and In above so these should be DotsPerCm and DotsPerIn
Comment 4 Kiet Ho 2021-08-27 14:50:53 PDT
(In reply to Simon Fraser (smfr) from comment #3)
> Comment on attachment 436675 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=436675&action=review
> 
> > Source/WebCore/css/CSSUnits.h:64
> > +    DotsPerInch = 31,
> > +    DotsPerCentimeter = 32,
> 
> We use Cm and In above so these should be DotsPerCm and DotsPerIn

Or we could change Cm => Centimeter and In => Inch, let me know your preference.
Comment 5 Kiet Ho 2021-08-30 09:52:53 PDT
I'm putting on hold before https://bugs.webkit.org/show_bug.cgi?id=229672 and https://bugs.webkit.org/show_bug.cgi?id=204276 is resolved.
Comment 6 Radar WebKit Bug Importer 2021-09-03 12:18:17 PDT
<rdar://problem/82734077>
Comment 7 Ahmad Saleem 2022-10-09 06:11:58 PDT
It seems that r+ patch didn't landed and this change is also not implemented. Example:

https://github.com/WebKit/WebKit/blob/387077670b14ff83b0f1ea2c1f65be35ad962ad0/Source/WebCore/animation/CSSPropertyAnimation.cpp#L472

Do we need this? Thanks!