Bug 229157 - REGRESSION (r281054): [ iOS14 ] fast/events/touch/ios/long-press-then-drag-to-select-text.html is a constant text failure
Summary: REGRESSION (r281054): [ iOS14 ] fast/events/touch/ios/long-press-then-drag-to...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-08-16 12:35 PDT by Robert Jenner
Modified: 2021-08-16 15:58 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Jenner 2021-08-16 12:35:10 PDT
fast/events/touch/ios/long-press-then-drag-to-select-text.html

is a constant text failure on iOS 14. 

HISTORY:
https://results.webkit.org/?suite=layout-tests&test=fast%2Fevents%2Ftouch%2Fios%2Flong-press-then-drag-to-select-text.html

TEXT DIFF:
-PASS: Correct Selection
-PASS: Correct Selection
+FAIL: failed to select a word as a result of a long press. Incorrect Selection:
+FAIL: failed to reduce selection to a single character by dragging down. Incorrect Selection:
 
This test started to constantly fail at r281054: https://trac.webkit.org/changeset/281054/webkit

It looks like changes were meant for iOS15, but have also had an impact on iOS14 testing.
Comment 1 Radar WebKit Bug Importer 2021-08-16 12:36:17 PDT
<rdar://problem/81993820>
Comment 2 Wenson Hsieh 2021-08-16 12:38:15 PDT
It's surprising to me that we attempt to run this test in OpenSource bots, considering that it's under fast/events/touch/ios. That said, this test doesn't rely on touch events, that's not necessarily a bad thing.
Comment 3 Wenson Hsieh 2021-08-16 12:42:55 PDT
> It looks like changes were meant for iOS15, but have also had an impact on
> iOS14 testing.

The changes were not specifically targeted for iOS 14 or 15.
Comment 4 Robert Jenner 2021-08-16 12:51:22 PDT
(In reply to Wenson Hsieh from comment #3)
> > It looks like changes were meant for iOS15, but have also had an impact on
> > iOS14 testing.
> 
> The changes were not specifically targeted for iOS 14 or 15.

That's good to know. I haven't dug too far into the details for this yet. My assumption for the targeting was because the bug that introduced this failure was titled with [ iOS 15 ]
Comment 5 Wenson Hsieh 2021-08-16 12:52:52 PDT
Oh, I think I know what's going on.

After r281054, `fast/events/touch/ios/long-press-then-drag-to-select-text.html` is now  the first test that's run in OpenSource inside the `fast/events/touch/ios` directory. There's probably a latent bug that causes `long-press-then-drag-to-select-text.html` to fail if it's run using a newly-created WKWebView.

My patch made us stop running `fast/events/touch/ios/long-press-on-link.html` in OpenSource, since that test was marked as PASS for iOS 14 and I removed that PASS expectation (along with the more broad CRASH expectation for all iOS).

This means we fall back to the directory-level expectations in `fast/events/touch/ios`, which is skipped in OpenSource. Prior to r281054, this test was the first in its directory; now, long-press-then-drag-to-select-text.html is the first test.

I suspect that *restoring* the PASS expectation for `long-press-on-link.html` will "fix" this test failure by making long-press-on-link.html the first test in its directory again. It seems okay to do this too, because `long-press-on-link.html` is a test that we eventually do want to run in open source bots, because it doesn't depend on touch events.
Comment 6 Wenson Hsieh 2021-08-16 12:59:20 PDT
Committed r281103 (240562@main): <https://commits.webkit.org/240562@main>

Let's see if that "fixes" it.
Comment 7 Wenson Hsieh 2021-08-16 15:58:20 PDT
(In reply to Wenson Hsieh from comment #6)
> Committed r281103 (240562@main): <https://commits.webkit.org/240562@main>
> 
> Let's see if that "fixes" it.

https://results.webkit.org/?suite=layout-tests&test=fast%2Fevents%2Ftouch%2Fios%2Flong-press-then-drag-to-select-text.html is starting to show successful runs.