Bug 228744 - REGRESSION (r280541): [ BigSur Debug ] accessibility/roles-computedRoleString.html is timing out
Summary: REGRESSION (r280541): [ BigSur Debug ] accessibility/roles-computedRoleString...
Status: CLOSED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-08-03 11:42 PDT by ayumi_kojima
Modified: 2021-08-06 08:40 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ayumi_kojima 2021-08-03 11:42:51 PDT
accessibility/roles-computedRoleString.html

Is timing out on BigSur Debug.

History: https://results.webkit.org/?suite=layout-tests&test=accessibility%2Froles-computedRoleString.html

No diff is available.
Comment 1 Radar WebKit Bug Importer 2021-08-03 11:43:14 PDT
<rdar://problem/81472432>
Comment 2 ayumi_kojima 2021-08-04 09:42:40 PDT
I was able to reproduce the timeout using:

run-webkit-tests --iterations 50 --exit-after-n-failures 1 --exit-after-n-crashes-or-timeouts 1 --debug accessibility/roles-computedRoleString.html

Though regression point is clear according to the history, test timed out at TOT, r280534 (seemingly regression started), r280531 (before regression), r279828 (one revision prior to the last change in the test).
Comment 3 ayumi_kojima 2021-08-04 09:47:48 PDT
Updated test expectations while investing https://trac.webkit.org/changeset/280636/webkit
Comment 4 ayumi_kojima 2021-08-04 11:18:20 PDT
It looks like the timeout started at https://trac.webkit.org/changeset/280541/webkit
Comment 5 Chris Dumez 2021-08-04 11:59:14 PDT
Committed r280649 (240260@main): <https://commits.webkit.org/240260@main>
Comment 6 Ryan Haddad 2021-08-05 16:10:41 PDT
It appears that this is resolved for Apple Silicon machines, but the test is still timing out on Intel bots.
Comment 7 Chris Dumez 2021-08-05 16:11:19 PDT
Reopening as it seems this is still happening.
Comment 8 Chris Dumez 2021-08-05 16:43:21 PDT
I can reproduce the time out locally. Reverting r280541 does not fix the timeout for me though. As a matter of fact, I don't even see setInnerText() getting called during that test.

I am not sure we have the regression point right.
Comment 9 Chris Dumez 2021-08-05 17:11:04 PDT
It looks like the test is very slow. This is why it only times out on debug bots and only on some hardware. I took a trace and we seems to be spending a lot of time under AXLogger::log() (which ends up calling Element::outerHTML()).

r280541 probably slowed down setInnerText a bit and it caused the test to time out. In r280649, I updated the test to stop using setInnerText and it made the test a bit faster, allowing it to pass on some hardware but not all.
Comment 10 Chris Dumez 2021-08-05 17:23:40 PDT
Committed r280708 (240303@main): <https://commits.webkit.org/240303@main>