Bug 22865 - Add WML <table>/<tr>/<td> element support
Summary: Add WML <table>/<tr>/<td> element support
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: XML (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nikolas Zimmermann
URL:
Keywords:
Depends on:
Blocks: 20393
  Show dependency treegraph
 
Reported: 2008-12-15 09:16 PST by Nikolas Zimmermann
Modified: 2008-12-15 16:26 PST (History)
1 user (show)

See Also:


Attachments
Initial patch (24.64 KB, patch)
2008-12-15 15:08 PST, Nikolas Zimmermann
oliver: review+
Details | Formatted Diff | Diff
LayoutTests (34.16 KB, patch)
2008-12-15 15:09 PST, Nikolas Zimmermann
oliver: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nikolas Zimmermann 2008-12-15 09:16:50 PST
I've finished porting the original WML table code from Yichaos patch into the new WML framework. The code has completely changed because I've stepped away from using HTMLCollection (old WMLTableElement used to inheritt from HTMLTableElement) and do all needed tasks manually.

I've noticed that the 'columns' attribute support, doesn't look right - as it was designed initially. For instance if there is 'columns=2' specified, and there are three columns present, the code just aggregated the two last <td> elements in a single <td> element (<td> <td/> <td/> </td>). That doesn't look right according to the spec, as the actual cell _content_ should be joined, not the cell elements itself.

I'm just fixing this, and will come up with a patch soon, completing WML table support.
Comment 1 Nikolas Zimmermann 2008-12-15 15:08:36 PST
Created attachment 26033 [details]
Initial patch
Comment 2 Nikolas Zimmermann 2008-12-15 15:09:04 PST
Created attachment 26034 [details]
LayoutTests
Comment 3 Nikolas Zimmermann 2008-12-15 16:26:41 PST
Landed in r39321.