Bug 22856 - Crash in <use> code in svg fireworks demo
Summary: Crash in <use> code in svg fireworks demo
Status: RESOLVED DUPLICATE of bug 23586
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.5
: P1 Normal
Assignee: Nobody
URL: http://www.carto.net/neumann/svg/svgf...
Keywords:
Depends on: 23586 25092
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-14 14:07 PST by Gustavo Delfino
Modified: 2010-01-17 17:23 PST (History)
2 users (show)

See Also:


Attachments
stacktrace of ASSERT (34.95 KB, text/plain)
2009-04-29 12:34 PDT, Eric Seidel (no email)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo Delfino 2008-12-14 14:07:34 PST
This SVG fireworks demo crashes webkit r39293
Comment 1 Eric Seidel (no email) 2009-04-28 17:17:56 PDT
This hits an ASSERT when run in debug mode:

ASSERTION FAILED: element->parentNode()
(/Users/eseidel/Projects/WebKit/WebCore/svg/SVGUseElement.cpp:722 void WebCore::SVGUseElement::expandSymbolElementsInShadowTree(WebCore::Node*))
Comment 2 Eric Seidel (no email) 2009-04-28 17:18:13 PDT
repro crashers are P1
Comment 3 Eric Seidel (no email) 2009-04-29 12:33:43 PDT
This is likely a dupe of either bug 23586 or bug 25092.
Comment 4 Eric Seidel (no email) 2009-04-29 12:34:41 PDT
Created attachment 29888 [details]
stacktrace of ASSERT
Comment 5 Rahul Kuchhal 2009-10-22 14:49:39 PDT
Duplicate of 23586?
Comment 6 Nikolas Zimmermann 2010-01-17 17:23:57 PST

*** This bug has been marked as a duplicate of bug 23586 ***