Bug 22854 - <source> tag not selected by css
Summary: <source> tag not selected by css
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-14 12:07 PST by Georges Marfurt
Modified: 2010-08-06 06:29 PDT (History)
2 users (show)

See Also:


Attachments
reduced html file (662 bytes, text/html)
2008-12-14 12:10 PST, Georges Marfurt
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Georges Marfurt 2008-12-14 12:07:51 PST
The reducted html works not as expected  with webkit r39286
It does in Firefox 3.0.1
Comment 1 Georges Marfurt 2008-12-14 12:10:57 PST
Created attachment 26013 [details]
reduced html file
Comment 2 Anthony Ricaud 2008-12-15 00:37:04 PST
Confirmed with r39230
Comment 3 Georges Marfurt 2010-08-06 03:15:18 PDT
i hoped the new html5 parsing engine (r64727) would finally solve this 
problem, but it's not the case.
Comment 4 Alexey Proskuryakov 2010-08-06 06:29:02 PDT
What exactly is the problem here? Both Firefox and Safari render the lines as red, black, green. With nightly r64816, the DOM is even exactly the same as in Firefox 3.6.6.

I think the difference with Firefox 3.0.1 was caused by it lacking support for <video> element - <source> is part of it, and it has special requirements on where it can appear in the document.

As far as I can tell, this behaves correctly.