Bug 22836 - Add new layout tests for transforms, animations & transitions
Summary: Add new layout tests for transforms, animations & transitions
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.5
: P2 Normal
Assignee: Pierre-Olivier Latour
URL:
Keywords:
: 22761 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-12 17:32 PST by Pierre-Olivier Latour
Modified: 2008-12-17 20:16 PST (History)
2 users (show)

See Also:


Attachments
Patch (37.82 KB, patch)
2008-12-12 18:11 PST, Pierre-Olivier Latour
sam: review+
Details | Formatted Diff | Diff
Extra Patch (3.07 KB, patch)
2008-12-15 12:52 PST, Pierre-Olivier Latour
mitz: review+
Details | Formatted Diff | Diff
Other Patch (4.23 KB, patch)
2008-12-15 13:41 PST, Pierre-Olivier Latour
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre-Olivier Latour 2008-12-12 17:32:17 PST
We have several new layout tests for transforms, animations & transitions we need to land in TOT
Comment 1 Pierre-Olivier Latour 2008-12-12 18:11:46 PST
Created attachment 25995 [details]
Patch
Comment 2 Pierre-Olivier Latour 2008-12-15 11:49:34 PST
Sending        LayoutTests/ChangeLog
Adding         LayoutTests/animations/combo-transform-translate+scale-expected.txt
Adding         LayoutTests/animations/combo-transform-translate+scale.html
Adding         LayoutTests/transforms/2d/computed-style-origin-expected.txt
Adding         LayoutTests/transforms/2d/computed-style-origin.html
Adding         LayoutTests/transforms/2d/transform-value-types-expected.txt
Adding         LayoutTests/transforms/2d/transform-value-types.html
Deleting       LayoutTests/transforms/computed-style-origin-expected.txt
Deleting       LayoutTests/transforms/computed-style-origin.html
Deleting       LayoutTests/transforms/transform-value-types-expected.txt
Deleting       LayoutTests/transforms/transform-value-types.html
Adding         LayoutTests/transitions/interrupt-transform-transition-expected.txt
Adding         LayoutTests/transitions/interrupt-transform-transition.html
Adding         LayoutTests/transitions/start-transform-transition-expected.txt
Adding         LayoutTests/transitions/start-transform-transition.html
Adding         LayoutTests/transitions/transition-timing-function-software-expected.txt
Adding         LayoutTests/transitions/transition-timing-function-software.html
Adding         LayoutTests/transitions/zero-duration-in-list-expected.txt
Adding         LayoutTests/transitions/zero-duration-in-list.html
Adding         LayoutTests/transitions/zero-duration-without-units-expected.txt
Adding         LayoutTests/transitions/zero-duration-without-units.html
Transmitting file data ...............
Committed revision 39307.

Comment 3 Pierre-Olivier Latour 2008-12-15 12:19:02 PST
Actually, something went wrong during file relocation, so I had to recommit a couple files:

Sending        LayoutTests/ChangeLog
Sending        LayoutTests/transforms/2d/transform-value-types-expected.txt
Sending        LayoutTests/transforms/2d/transform-value-types.html
Transmitting file data ...
Committed revision 39308.

Comment 4 Pierre-Olivier Latour 2008-12-15 12:52:37 PST
Created attachment 26029 [details]
Extra Patch

I found another animation test we missed
Comment 5 Pierre-Olivier Latour 2008-12-15 13:06:12 PST
Sending        LayoutTests/ChangeLog
Adding         LayoutTests/animations/combo-transform-rotate+scale-expected.txt
Adding         LayoutTests/animations/combo-transform-rotate+scale.html
Transmitting file data ...
Committed revision 39310.

Comment 6 Pierre-Olivier Latour 2008-12-15 13:41:48 PST
Created attachment 26030 [details]
Other Patch

Here's the (hopefully) final one
Comment 7 mitz 2008-12-15 13:49:19 PST
Comment on attachment 26030 [details]
Other Patch

rs=me. This should be switched over to the DRT API for manipulating time so that it doesn't need to use setTimeout.
Comment 8 Pierre-Olivier Latour 2008-12-15 13:51:51 PST
Sending        LayoutTests/ChangeLog
Adding         LayoutTests/transitions/change-values-during-transition-expected.txt
Adding         LayoutTests/transitions/change-values-during-transition.html
Transmitting file data ...
Committed revision 39312.

Comment 9 Simon Fraser (smfr) 2008-12-17 20:16:01 PST
*** Bug 22761 has been marked as a duplicate of this bug. ***