Bug 228167 - [iOS Debug] media/media-fragments/TC0003.html is flaky crashing
Summary: [iOS Debug] media/media-fragments/TC0003.html is flaky crashing
Status: RESOLVED DUPLICATE of bug 228038
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: WebKit Nightly Build
Hardware: iPhone / iPad Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-07-21 15:38 PDT by ayumi_kojima
Modified: 2021-07-21 18:15 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ayumi_kojima 2021-07-21 15:38:39 PDT
media/media-fragments/TC0003.html

Is flaky crashing on iOS 14 E Simulator wk2 Debug.

History: https://results.webkit.org/?suite=layout-tests&test=media%2Fmedia-usage-state-private-browsing.html

The crash started showing in the history on around 5/13/2021. Test results are not available before 5/13/2021.

I was not able to reproduce the crash on a simulator (iOS 15) on my local machine using run-webkit-tests --iphone-simulator --iterations 50 --debug -f --exit-after-n-failures 2 --exit-after-n-crashes-or-timeouts 2 media/media-fragments/TC0003.html

It timed out instead.

Crash log:

ASSERTION FAILED: !m_messageReceiverMapCount
/Volumes/Data/worker/ios-simulator-14-debug/build/Source/WebKit/Platform/IPC/MessageReceiver.h(41) : virtual IPC::MessageReceiver::~MessageReceiver()
1   0x4dd437a19 WTFCrash
2   0x4c00b0e3b WTFCrashWithInfo(int, char const*, char const*, int)
3   0x4c00f5e48 IPC::MessageReceiver::~MessageReceiver()
4   0x4c1db6d3e WebKit::RemoteAudioHardwareListener::~RemoteAudioHardwareListener()
5   0x4c1db6e85 WebKit::RemoteAudioHardwareListener::~RemoteAudioHardwareListener()
6   0x4c1db6eec WebKit::RemoteAudioHardwareListener::~RemoteAudioHardwareListener()
7   0x4e62c5c1f std::__1::default_delete<WebCore::AudioHardwareListener>::operator()(WebCore::AudioHardwareListener*) const
8   0x4e62c5be2 WTF::RefCounted<WebCore::AudioHardwareListener, std::__1::default_delete<WebCore::AudioHardwareListener> >::deref() const
9   0x4e62c5b67 WTF::DefaultRefDerefTraits<WebCore::AudioHardwareListener>::derefIfNotNull(WebCore::AudioHardwareListener*)
10  0x4e792d304 WTF::RefPtr<WebCore::AudioHardwareListener, WTF::RawPtrTraits<WebCore::AudioHardwareListener>, WTF::DefaultRefDerefTraits<WebCore::AudioHardwareListener> >::operator=(std::nullptr_t)
11  0x4e792d2be WebCore::MediaSessionManagerCocoa::removeSession(WebCore::PlatformMediaSession&)
12  0x4ea07d8cf WebCore::PlatformMediaSession::stopSession()
13  0x4e93dbb1c WebCore::HTMLMediaElement::stop()
14  0x4e9025bcd auto WebCore::ScriptExecutionContext::stopActiveDOMObjects()::$_3::operator()<WebCore::ActiveDOMObject>(WebCore::ActiveDOMObject&) const
15  0x4e9025b63 WTF::Detail::CallableWrapper<WebCore::ScriptExecutionContext::stopActiveDOMObjects()::$_3, WebCore::ScriptExecutionContext::ShouldContinue, WebCore::ActiveDOMObject&>::call(WebCore::ActiveDOMObject&)
16  0x4e900e41a WTF::Function<WebCore::ScriptExecutionContext::ShouldContinue (WebCore::ActiveDOMObject&)>::operator()(WebCore::ActiveDOMObject&) const
17  0x4e900e270 WebCore::ScriptExecutionContext::forEachActiveDOMObject(WTF::Function<WebCore::ScriptExecutionContext::ShouldContinue (WebCore::ActiveDOMObject&)> const&) const
18  0x4e900e787 WebCore::ScriptExecutionContext::stopActiveDOMObjects()
19  0x4e8dcd7ef WebCore::Document::stopActiveDOMObjects()
20  0x4e8dcd58c WebCore::Document::commonTeardown()
21  0x4e8ddaa64 WebCore::Document::willBeRemovedFromFrame()
22  0x4e9d7bd73 WebCore::Frame::setView(WTF::RefPtr<WebCore::FrameView, WTF::RawPtrTraits<WebCore::FrameView>, WTF::DefaultRefDerefTraits<WebCore::FrameView> >&&)
23  0x4e9d812dd WebCore::Frame::createView(WebCore::IntSize const&, std::__1::optional<WebCore::Color> const&, WebCore::IntSize const&, WebCore::IntRect const&, bool, WebCore::ScrollbarMode, bool, WebCore::ScrollbarMode, bool)
24  0x4c2028197 WebKit::WebFrameLoaderClient::transitionToCommittedForNewPage()
25  0x4e9b3c084 WebCore::FrameLoader::transitionToCommitted(WebCore::CachedPage*)
26  0x4e9b3ac97 WebCore::FrameLoader::commitProvisionalLoad()
27  0x4e9ab40cc WebCore::DocumentLoader::commitIfReady()
28  0x4e9ab4931 WebCore::DocumentLoader::finishedLoading()
29  0x4e9ac1411 WebCore::DocumentLoader::maybeLoadEmpty()
30  0x4e9ac1595 WebCore::DocumentLoader::startLoadingMainResource()
31  0x4e9b6567d WebCore::FrameLoader::continueLoadAfterNavigationPolicy(WebCore::ResourceRequest const&, WebCore::FormState*, WebCore::NavigationPolicyDecision, WebCore::AllowNavigationToInvalidURL)::$_11::operator()()
com.apple.WebKit.WebContent.Development terminated (pid 67975) because the process crashed
Comment 1 Radar WebKit Bug Importer 2021-07-21 15:39:03 PDT
<rdar://problem/80922039>
Comment 2 ayumi_kojima 2021-07-21 15:44:39 PDT
Updated test expectations https://trac.webkit.org/changeset/280164/webkit
Comment 3 Alexey Proskuryakov 2021-07-21 18:15:26 PDT

*** This bug has been marked as a duplicate of bug 228038 ***