Bug 228022 - Images as grid items should use the overridingLogicalWidth when defined to compute the logical Height
Summary: Images as grid items should use the overridingLogicalWidth when defined to co...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: zsun
URL:
Keywords: InRadar
: 228325 232922 (view as bug list)
Depends on: 228325 233184
Blocks:
  Show dependency treegraph
 
Reported: 2021-07-16 05:31 PDT by zsun
Modified: 2021-11-19 10:50 PST (History)
12 users (show)

See Also:


Attachments
Patch (12.61 KB, patch)
2021-07-16 07:02 PDT, zsun
no flags Details | Formatted Diff | Diff
Patch (12.23 KB, patch)
2021-07-19 09:48 PDT, zsun
no flags Details | Formatted Diff | Diff
Patch (12.27 KB, patch)
2021-07-20 01:04 PDT, zsun
no flags Details | Formatted Diff | Diff
Patch (12.22 KB, patch)
2021-07-27 02:06 PDT, zsun
no flags Details | Formatted Diff | Diff
Patch (10.19 KB, text/plain)
2021-07-27 02:54 PDT, zsun
no flags Details
Patch (14.22 KB, patch)
2021-11-16 07:09 PST, zsun
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description zsun 2021-07-16 05:31:25 PDT
RenderReplaced as grid items should use the overridingLogicalWidth when defined to compute the logical height.
Comment 1 zsun 2021-07-16 07:02:20 PDT
Created attachment 433673 [details]
Patch
Comment 2 Javier Fernandez 2021-07-17 03:04:21 PDT
Comment on attachment 433673 [details]
Patch

r=me
Comment 3 EWS 2021-07-19 01:39:46 PDT
Tools/Scripts/svn-apply failed to apply attachment 433673 [details] to trunk.
Please resolve the conflicts and upload a new patch.
Comment 4 zsun 2021-07-19 09:48:55 PDT
Created attachment 433795 [details]
Patch
Comment 5 EWS 2021-07-19 12:56:11 PDT
/Volumes/Data/worker/Commit-Queue/build/Source/WebCore/ChangeLog neither lists a valid reviewer nor contains the string "Unreviewed" or "Rubber stamp" (case insensitive).
Comment 6 zsun 2021-07-20 01:04:11 PDT
Created attachment 433854 [details]
Patch
Comment 7 EWS 2021-07-20 04:26:34 PDT
Committed r280078 (239804@main): <https://commits.webkit.org/239804@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 433854 [details].
Comment 8 Radar WebKit Bug Importer 2021-07-20 04:27:17 PDT
<rdar://problem/80831713>
Comment 9 Truitt Savell 2021-07-26 13:30:16 PDT
It looks like the changes in https://trac.webkit.org/changeset/280078/webkit

broke fast/images/exif-orientation-composited.html on windows 

history:
https://results.webkit.org/?suite=layout-tests&test=fast%2Fimages%2Fexif-orientation-composited.html

Diff:
https://ews-build.s3-us-west-2.amazonaws.com/Windows-EWS/r433795-100045/fast/images/exif-orientation-composited-diffs.html

It looks like the test is no longer outputting some text.
Comment 10 Truitt Savell 2021-07-26 13:37:34 PDT
This is affecting windows EWS badly so we will need a fix or to revert this change.
Comment 11 zsun 2021-07-27 02:06:45 PDT
Created attachment 434277 [details]
Patch
Comment 12 zsun 2021-07-27 02:54:19 PDT
Created attachment 434279 [details]
Patch
Comment 13 zsun 2021-07-27 08:25:14 PDT
(In reply to Truitt Savell from comment #9)
> It looks like the changes in https://trac.webkit.org/changeset/280078/webkit
> 
> broke fast/images/exif-orientation-composited.html on windows 
> 
> history:
> https://results.webkit.org/?suite=layout-tests&test=fast%2Fimages%2Fexif-
> orientation-composited.html
> 
> Diff:
> https://ews-build.s3-us-west-2.amazonaws.com/Windows-EWS/r433795-100045/fast/
> images/exif-orientation-composited-diffs.html
> 
> It looks like the test is no longer outputting some text.

Thank you. This is addressed at Bug 228325.
Comment 14 zsun 2021-11-16 07:09:41 PST
Created attachment 444373 [details]
Patch
Comment 15 Javier Fernandez 2021-11-17 02:18:25 PST
Comment on attachment 444373 [details]
Patch

r=me 

The changes looks good; it seems the only difference with the version we had landed is that now the caller is the grid item, as it should have been. 

However, I wonder whether we need also the lines removed in the patch to fix the bug #228325. Perhaps that regression was caused by the error we are fixing now in this patch, due to calling constrainLogicalWidthInFragmentByMinMax from the grid container .
Comment 16 EWS 2021-11-18 05:12:35 PST
Committed r285998 (244395@main): <https://commits.webkit.org/244395@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 444373 [details].
Comment 17 zsun 2021-11-18 05:25:10 PST
*** Bug 228325 has been marked as a duplicate of this bug. ***
Comment 18 Gabriel Nava Marino 2021-11-19 10:50:16 PST
*** Bug 232922 has been marked as a duplicate of this bug. ***