Bug 227954 - HTML Canvas drop shadow rendering issues on Safari 14.1.2 beta
Summary: HTML Canvas drop shadow rendering issues on Safari 14.1.2 beta
Status: RESOLVED DUPLICATE of bug 197689
Alias: None
Product: WebKit
Classification: Unclassified
Component: Canvas (show other bugs)
Version: Safari 14
Hardware: Mac (Intel) macOS 10.15
: P2 Normal
Assignee: Nobody
URL: https://bug-197689-attachments.webkit...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-14 09:00 PDT by sam.shiels
Modified: 2021-10-05 08:48 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sam.shiels 2021-07-14 09:00:48 PDT
Apologies, this is similar to https://bugs.webkit.org/show_bug.cgi?id=197689#c2
I can't seem to find out if this problem is being addressed in subsequent versions of Safari 14.1.2. Hence the re-log.

I'm experiencing a similar issue where HTML Canvas strokes are being rendered incorrectly on Safari 14.1.2 beta. They appear to render in a completely incorrect position when using a gradient fill. The best example of the issue that I've seen can be found in the link above.

This doesn't occur on Chrome, Firefox or any version of Safari other than 14.1.2 beta.
Comment 1 Alexey Proskuryakov 2021-07-15 18:06:12 PDT
I can reproduce this issue with Safari 14.1.1 on macOS 11.4, not just with Safari 14.1.2 beta.

Could you please provide exact details of machines where this worked as expected for you in Safari, such as hardware model, display, macOS versions?
Comment 2 Simon Fraser (smfr) 2021-07-15 19:46:49 PDT
I can reproduce. Turning off accelerated canvas does not fix it.
Comment 3 Simon Fraser (smfr) 2021-07-15 19:47:45 PDT

*** This bug has been marked as a duplicate of bug 197689 ***
Comment 4 sam.shiels 2021-07-16 00:32:28 PDT
(In reply to Alexey Proskuryakov from comment #1)
> I can reproduce this issue with Safari 14.1.1 on macOS 11.4, not just with
> Safari 14.1.2 beta.
> 
> Could you please provide exact details of machines where this worked as
> expected for you in Safari, such as hardware model, display, macOS versions?

Sure.

MacBook Pro (15-inch, 2018)
macOS Catalina 10.15.7 (19H2)
Dell U2719D
Builtin Retina Display
Comment 5 sam.shiels 2021-07-26 06:10:32 PDT
(In reply to Alexey Proskuryakov from comment #1)
> I can reproduce this issue with Safari 14.1.1 on macOS 11.4, not just with
> Safari 14.1.2 beta.
> 
> Could you please provide exact details of machines where this worked as
> expected for you in Safari, such as hardware model, display, macOS versions?

Hi Alexey, do you have any further information on this?
Comment 6 sam.shiels 2021-10-05 03:49:21 PDT
Hi again. Does anyone have any updates/advice around this issue?
Comment 7 Alexey Proskuryakov 2021-10-05 08:48:54 PDT
> Does anyone have any updates/advice around this issue?

No. Please watch the original for updates, or even fix it yourself - this is an open source project that welcomes contributors.

*** This bug has been marked as a duplicate of bug 197689 ***