Bug 227928 - Can't access WinCairo test results
Summary: Can't access WinCairo test results
Status: RESOLVED DUPLICATE of bug 223216
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Don Olmstead
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-13 16:25 PDT by Alex Christensen
Modified: 2021-07-20 12:58 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Christensen 2021-07-13 16:25:06 PDT
When I go to https://build.webkit.org/results/WinCairo-64-bit-WKL-Debug-Tests/r279815%20(689)/results.html then click on the diffs, I get 403 errors.  The solution apparently has to do with changing the umask or chmod or something.
Comment 1 Aakash Jain 2021-07-13 16:28:37 PDT
The individual files created by the wincairo bots have very restrictive file permissions. We simply unzip the results and host them. The bots (probably buildbot.tac for buildbot-worker) should use umask = 022
Comment 2 Don Olmstead 2021-07-13 16:31:06 PDT
We are using that umask any other things to look at?

https://github.com/WebKitForWindows/docker-webkit-dev/blob/master/buildbot/WebKit-BuildWorker/buildbot.tac.tmpl#L35
Comment 3 Fujii Hironori 2021-07-13 18:26:30 PDT
Same issue with this.
Bug 223216 – Forbidden to access WinCairo Buildbot sub-directories of layout test results as "403 Forbidden"
Comment 4 Alexey Proskuryakov 2021-07-13 22:51:52 PDT
Perhaps it should be 0o022, as changed for Python 3 in https://trac.webkit.org/changeset/268935/webkit?
Comment 5 lingho@apple.com 2021-07-16 16:54:21 PDT
I went ahead and applied the ACL to WinCairo-64-bit-WKL-Debug-Tests/ directory, similar to what's done in https://bugs.webkit.org/show_bug.cgi?id=223216
Comment 6 Don Olmstead 2021-07-16 17:46:54 PDT
The test results Alex linked to aren’t 403ing anymore so this looks successful.

Should check after more builds before closing it.

Thanks for the assist!
Comment 7 Fujii Hironori 2021-07-20 12:58:53 PDT

*** This bug has been marked as a duplicate of bug 223216 ***