Bug 227721 - [Cairo] Merge PlatformContextCairo into GraphicsContextCairo
Summary: [Cairo] Merge PlatformContextCairo into GraphicsContextCairo
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Fujii Hironori
Keywords: InRadar
Depends on:
Reported: 2021-07-06 14:30 PDT by Fujii Hironori
Modified: 2021-07-12 12:18 PDT (History)
17 users (show)

See Also:

WIP patch (547 bytes, patch)
2021-07-06 14:31 PDT, Fujii Hironori
no flags Details | Formatted Diff | Diff
WIP patch (75.07 KB, patch)
2021-07-06 14:31 PDT, Fujii Hironori
ews-feeder: commit-queue-
Details | Formatted Diff | Diff
WIP patch (75.21 KB, patch)
2021-07-06 14:44 PDT, Fujii Hironori
no flags Details | Formatted Diff | Diff
Patch (85.56 KB, patch)
2021-07-06 17:30 PDT, Fujii Hironori
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fujii Hironori 2021-07-06 14:30:03 PDT
[Cairo] Merge PlatformContextCairo into GraphicsContextCairo

PlatformContextCairo was originally introduced to separate Cairo
specific code from the platform-independent GraphicsContext.
However, GraphicsContext is a virtual class nowadays. And,
GraphicsContextCairo is a Cairo specifix concrete class.
Comment 1 Fujii Hironori 2021-07-06 14:31:13 PDT
Created attachment 432972 [details]
WIP patch
Comment 2 Fujii Hironori 2021-07-06 14:31:51 PDT
Created attachment 432973 [details]
WIP patch
Comment 3 Fujii Hironori 2021-07-06 14:44:53 PDT
Created attachment 432975 [details]
WIP patch
Comment 4 Fujii Hironori 2021-07-06 17:20:04 PDT
EWS style checker failed.

> ERROR: Source/WebCore/platform/graphics/cairo/GraphicsContextGLCairo.cpp:34:  Found header this file implements after other header. Should be: config.h, primary header, blank line, and then alphabetically sorted.  [build/include_order] [4]

check-webkit-style considers "GraphicsContext.h" is the primary header for GraphicsContextGLCairo.cpp.
I think GraphicsContextGLCairo.cpp should be renamed to GraphicsContextGLOpenGLCairo.cpp to make "GraphicsContextGLOpenGL.h" the primary header.
Comment 5 Fujii Hironori 2021-07-06 17:30:57 PDT
Created attachment 432992 [details]
Comment 6 Don Olmstead 2021-07-07 11:09:24 PDT
Comment on attachment 432992 [details]

Comment 7 Fujii Hironori 2021-07-07 12:44:06 PDT
Comment on attachment 432992 [details]

Clearing flags on attachment: 432992

Committed r279658 (239471@main): <https://commits.webkit.org/239471@main>
Comment 8 Fujii Hironori 2021-07-07 12:44:10 PDT
All reviewed patches have been landed.  Closing bug.
Comment 9 Radar WebKit Bug Importer 2021-07-07 12:45:19 PDT
Comment 10 Fujii Hironori 2021-07-08 21:43:42 PDT
This change causes new test crashes.
Filed: Bug 227827 – [WinCairo] drag tests are crashing after r279658
Comment 11 Tim Horton 2021-07-12 12:18:38 PDT
Nice, thank you for doing some follow-through on the refactor! This is great :)